Rclone fatal error mount not ready & Plex not finding Files [SFTP]

Hello,

What is the problem you are having with rclone?

I'm new to all of this, so trying to google things, and this is how far I've got.
So the problem I'm having now is trying to Mount a Backup Server; it's getting Mounted (without --daemon) but having Two issues -

  1. I believe I can see the mount under Plex Server, but no files are found.

  2. When I try to select the folder under /home/user/Plex (where the Mount is supposed to be, it's Greyed out).

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1
-os/version: ubuntu 20.04 (64 bit)
-os/kernal: 5.4.0 (x86_64)
-os/type: linux
-os/arch: amd64
-go/version: go1.19.4
-go/linking: static
-go/tags: none

Are you on the latest version of rclone?

Yes, the latest is 1.61.1

Which cloud storage system are you using? (eg Google Drive)

Using NetDynamics24 Server. SFTP. 

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I tried different mount methods here, so I'll list all of them here, the latter being the latest command.

-- 1st

rclone mount Legion: /home/user/Plex


--2nd
rclone mount -v --read-only --gid 33 --umask 0027 --dir-cache-time 300h --daemon Legion: /home/user/Plex

This gave me - "mount not ready"




-- 3rd command used.

rclone mount -v --read-only --gid 33 --umask 0027 --dir-cache-time 300h --vfs-cache-mode full --vfs-cache-max-size 300G Legion: /home/user/Plex

Entering the last command gives me:

2023/01/13 13:46:51 INFO : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0 total size 0. 

I've had the last line appear every minute in the terminal around 20 times.

The rclone config contents with secrets removed.

-type: sftp
-host: IP Address
-user: desibuoy
-pass: *** Encrypted ***
-shell_type: unix
-md5sum_command: md5sum
-shalsum_command: sha1sum

A log from the command with the -vv flag

Not sure which command to run to produce this log.

Extra Information

The last command I used was from another rclone config; I added

--vfs cache
-v
--read-only 
--gid 33 
--umask 0027 
--dir-cache-time 300h 

(I have no idea what any of it means but I just made an assumption as one person was trying to get his 4K Files to stream without freezing or buffering, and the other dude got his working using the gid, umask and dir-cache commands) I just thought if I add 300G, it will cache the file so then it would play it smoothly. My biggest file is around 250G.

I know I assumed with the commands. Honestly, I just wanted to try things out and get it to eventually work and not use up all of yours free time, but now I'm stuck and have no idea how to go about and fix it. I would appreciate it if anyone could help me. I am also using the remote desktop connection to my seedbox to type all the commands in the terminal

Simply put, trying to play a mounted folder under Plex, to stream 4K content, but I don't want to keep remounting. I know other members on the web have had where their files disappear for X amount of time.

Many thanks for considering my request.

hello and welcome to the forum,

try adding --allow-other

best to test using a simple mount command, get that to work, then, if needed, tweak flags and values.
rclone mount /home/user/Plex -v --read-only --allow-other

that is expected, rclone is letting you know the status of the vfs file cache.

Hello asdffdsa,

I've tried adding --allow-other

2023/01/13 14:43:02 INFO : sftp://user@ip/Plex poll-interval is not supported by this remote
2023/01/13 14:43:02 INFO : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0 total size 0.
2023/01/13 14:43:02 INFO : mount helper error: fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
2023/01/13 14:43:02 INFO : Fatal error: failed to mount FUSE fs: fusermount: exit status 1

Sorry I thought there was only 1 response. I'll try the simple mount right now.


This simple command doesn't work as I'm getting the same error as above with --allow-other

rclone mount /home/user/Plex -v --read-only --allow-other

no worries, that is expected.

  1. edit /etc/fuse.conf,
  2. uncomment user_allow_other by removing the leading #
  3. save the file
  4. try the rclone mount command again.

Hi,

I don't have root :frowning: Let me speak to my seedbox provider to see if they can change this.

Thanks

which provider are you using?

I'm using rapidseedbox

Hi,

Sorry got busy with work but got this working now, I can see it mounted.

Got the same error, though.

ok, good
at this point, what else do you need help with?

Oh!! I just went to add the drive again and I can see the files there :smiley:

so now I want to know how I get it so that
A ) files don't disappear. Will this mount stay running in the background even after the server reboot? Other users on this forum/Reddit have mentioned files disappearing after a while.

B) I have 4K files. The biggest one is around 250G. What can I do so it can play without freezing and buffering in the original version? Do I need some kind of caching?

C) Out of Topic, what command do I need so that my downloaded files go directly to this folder but don't get deleted when I delete them off my seedbox? Every 3 or 6 hours. It's a shared server so don't want to take up too many resources.

Thank you.

nice!

that is expected, sftp is not a polling remote.
and that is not an ERROR, just a INFO, so ignore it.

need a way to run rclone mount at boot time, can do that with
--- systemd
--- cron

the cache is optional, some use it, some do not - try --vfs-cache-mode=full
as for the freezing, have to determine where the issue is?
--- vps internet connection
--- vps cpu - can the vps handle 4K streaming
--- with plex, does the client stream direct or transcoding. as transcoding can over-stress the cpu.
--- client internet connection.

need to use a vfs file cache - try --vfs-cache-mode=full

by default, the files will stay in the cache for one hour.
--vfs-cache-max-age duration Max age of objects in the cache (default 1h0m0s)

about the vfs file cache, rclone does not download the entire file.
so for example, if you stream one minute of a ninety minute movie, then in the cache, rclone saves just the chunks that were downloaded for that one minute.