Rclone failed to create file system with wasabi on OS X

What is the problem you are having with rclone?

Running this:
rclone --config /Users/amanda/.config/rclone/rclone.conf sync /Users/amanda wasabi:amandabackup

The above command gives me this error:
Failed to create file system for "wasabi:amandabackup": didn't find section in config file

I've also tried --config="" and even creating the config from scratch after deleting the old one. I've made sure my dashes and quotation marks are correct, and not copying over with weird formatting accents.

What is your rclone version (output from rclone version)

rclone: Version "v1.49.5"

Which OS you are using and how many bits (eg Windows 7, 64 bit)

OS X 10.11.6 El Capitan

Which cloud storage system are you using? (eg Google Drive)


A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

rclone -vv copy /tmp remote:tmp

Gives me:

DEBUG : rclone: Version "v1.49.5" starting with parameters ["rclone" "-vv" "copy" "/tmp" "remote:tmp"] DEBUG : Using config file from "/Users/amanda/.config/rclone/rclone.conf" Failed to create file system for "remote:tmp": didn't find section in config file

My config file

type = s3
provider = Wasabi
env_auth = false
access_key_id = My key would be here
secret_access_key = My Secret key would be here - both double checked accurate
endpoint = s3.us-west-1.wasabisys.com
acl = private
bucket_acl = private

I've been at this for hours. I use rclone easily on my Linux box, surprised I'm having issues on OS X however. Really need this to work as the GUI apps for Wasabi on OS X are horrid. Thanks!

welcome to the rclone forum,

you need to replace the word wasabi with the name of the remote.
the name of your remote is amandabackup, you need to use that.

rclone sync /Users/amanda wasabi:amandabackup
should be
rclone sync /Users/amanda amandabackup:bucketname

also, please note wasabi is experiencing major issues.
see https://status.wasabi.com/

as of now, i am not able to use wasabi reliably.

given that you are new and learning rclone, you should create buckets in the region of EU-Central.
i would not use the other regions that this time

about the gui, have you seen

Thanks so much! Reset a new bucket to the recommended region. Added my excludes without any issues. Tossed in the progress indicator too. All fantastic. Just like on my Linux box.

Doesn't look like I can switch my Linux box to EU-Central as I don't see where I can switch the existing Linux bucket over. But the Mac's bucket is now set and working well with EU-Central.

Much appreciated.

I tried Cyberduck, but it just didn't fit my needs. Used to using a CLI whenever possible (lightweight, can see errors, etc). Thanks

  1. good, glad to help. feel free to post anytime.

  2. i agree, cli is the way to go.

  3. have you considered a donation to the developer of rclone?
    i assure you that i do not get any of the donation.

1 Like

Agreed, will be doing so after payday. I contribute funds where I can in the FoSS space. Adding this to my list.

You would have to make a new remote with rclone config and then copy the data over from the old bucket to the new one with rclone sync. Then update your scripts to use the new remote.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.