Rclone "Failed to create file system: Didn't find section in config file" when trying to mount drive

HI, I'm pretty new to linux in general so please bare with me here. I'm having issues mounting my proton drive. Im running Manjaro with xfce desktop. I have the drive configured, I can use rclone lsd to see all my directories just fine. When I try to mount the drive using rclone mount as below I get the error also below:

sudo rclone mount "pdrive:" /Proton

I was also running it without the sudo with the same error, and also as root. /Proton is a simple directory I made.

Failed to create file system for "Proton Drive:": didn't find section in config file

I have also run it with the debug flag as:

sudo rclone mount "prdive:" /Proton -vv
2024/04/14 12:23:24 DEBUG : rclone: Version "v1.65.2" starting with parameters ["rclone" "mount" "prdive:" "/Proton" "-vv"]
DEBUG : Creating backend with remote "prdive:"
DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
Failed to create file system for "prdive:": didn't find section in config file

My rclone version:

rclone v1.65.2
- os/version: arch 23.1.4 (64 bit)
- os/kernel: 6.6.26-1-MANJARO (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.6
- go/linking: dynamic
- go/tags: none

The config file:

type = protondrive
username = XXX
password = XXX
2fa = XXX
client_uid = XXX
client_access_token = XXX
client_refresh_token = XXX
client_salted_key_pass = XXX
### Double check the config for sensitive info before posting publicly

I originally was running rclone from the snap package but uninstalled and tried the official manjaro repo version and the issue is the same. Any and all help is greatly appreciated.

Do not use snap version as it does not support mount.

You have problem because you created your remote as normal user and trying to run mount as root (sudo). Config file location is user dependent so every user can have own config file.

Is your config file there? Probably not.

Also not sure why you want to run mount as root. It is not needed.

Thanks for the reply. I ran it as su just because it didn't work running it normally. If I run it as user I get the same error. The config file is within the user .config folder under rclone and is as shown in my above post.

run then normally and post output here

So I think I managed to fix the issue, the location I created was /Proton in the top directory, when I created a new one within home/user it worked.

1 Like

Nothing stops you from using /Proton - however you have to make sure that your mount directory has full access rights for user running rclone mount.

Using ~/Proton is probably easier without any extra steps needed.

1 Like

That makes sense, thank you so much for your help its been greatly appreciated!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.