Rclone errors with OneDrive sync

Hello, since a couple of days I have been receiving errors when syncing my personal OneDrive to a local disk. The sync was working perfectly until March 9th.

The rclone version that I was using was an old one (1.45.something) but I upgraded to 1.54.1 using go version 1.15.8, and the problem persists.
My machine is a Debian Buster running kernel 4.19.0-14-amd64, it hasn't changed recently.

The disk I am syncing to is a normal ext4 filesystem.

The error I am receiving is:

error reading source directory: couldn't list files: InvalidAuthenticationToken: Unable to initialize RPS

I have already tried to remove the remote from .rclone.conf and make a new login on OneDrive.

I have found a similar bug reported in this forum (cannot add the link due to post restrictions: update-on-linux-kernel-5-4-and-rclone-mount-issue/13569/18) reported last year, but found no solution to that.

Can you help?

Thank you,

I have also found OneDrive sync fail after few minutes - #2 by ncw in which the suggestion to fix the issue was re-logging to OneDrive.

However, as said above, this has not worked in my case (I also double-checked and my computer time is correct)

hello and welcome to the forum,
when you posted there was a template of questions, that can help us to help you....

Hello jojothehumanmonkey, today I tried running the backup again to fill the bug template you suggested and found that - after three days - the rclone sync method on which I was getting the error (InvalidAuthenticationToken: Unable to initialize RPS) has started working again, without further changes on my side.

I presume that this kind of error is something happening on the OneDrive side, so I leave the explanation here in case somebody else has this problem in the future.

If I get again this error, I will report it with the bug report template to investigate it more.

Thank you,

good to know,

it is happens again, then update this post.

as this problem went away on its own, with no further changes, please do not use the bug report, instead use help and support template.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.