Rclone Error 404 : File not found

What is the problem you are having with rclone?

I am receiving the following error

Failed to ls: couldn't list directory: googleapi: Error 404: File not found: ., notFound

When initiating the command:

rclone ls MongoDB_Backup: --log-file=./reclone_log.txt

What is your rclone version (output from rclone version)

My version of rclone is : v1.56.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

I am using linux ubuntu 21.04 64-bit

Which cloud storage system are you using? (eg Google Drive)

I am using Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls MongoDB_Backup: --log-file=./rclone_log.txt

The rclone config contents with secrets removed.

type = drive
client_id = **redacted**
client_secret = **redacted**
scope = drive
root_folder_id = ""
token = {"access_token":"redacted","token_type":"Bearer","refresh_token":"redacted","expiry":"2021-08-06T10:56:51.459336124-06:00"}
team_drive =

A log from the command with the -vv flag

2021/08/06 10:42:26 DEBUG : rclone: Version "v1.56.0" starting with parameters ["rclone" "-vv" "ls" "MongoDB_Backup:"]
2021/08/06 10:42:26 DEBUG : Creating backend with remote "MongoDB_Backup:"
2021/08/06 10:42:26 DEBUG : Using config file from "/home/ubuntu/.config/rclone/rclone.conf"
2021/08/06 10:42:26 DEBUG : 4 go routines active
2021/08/06 10:42:26 Failed to ls: couldn't list directory: googleapi: Error 404: File not found: ., notFound

If I run it with sudo as sudo rclone ls MongoDB_Backup:, then it runs just fine. How can I run it without sudo and still have it run as intended?

Is it a team drive or a regular drive?

Did you run rclone config as root or your regular user?

regular drive. Configured as sudo.

not sure why you have that there.

Configuration files are per user so you want to run rclone config and connect it as the user you are planning to use.

The issue would be running the config / partially as one user, connecting as another, etc. There is a team drive note in the config the OP listed and it's not a team drive.

So it most likely works as root since it was properly configured and not as the user running as it probably has a partial config file.

Thank you. Yes, after just using rclone config without sudo, I can now perform rclone commands without receive the above error when not using sudo.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.