RClone --drive-server-side-across-configs flag doesn't work anymore between team drives

What is the problem you are having with rclone?

Copying via regular rclone copy works, but using the --drive-server-side-across-configs tag prompts a "File not found" error for all files in the directory. This is true when copying files between two team drives

What is your rclone version (output from rclone version)

v1.48

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win 10 64 bit/Ubuntu 18.0.4

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy -vv --drive-server-side-across-configs --max-transfer 400G GRemote_Test:/Test1/ GRemote:/Test2/

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

I'm getting something similar to the below:

2019/08/19 18:39:12 ERROR : Failed to copy: googleapi: Error 404: File not found: 1HVqr3s9UZlgNWsJez2TK85xTa_eAU., notFound

2019/08/19 18:39:12 ERROR : Failed to copy: googleapi: Error 404: File not found: 1SqZFnwwgmAWvEkTohYkkn-oZRuXp., notFound

2019/08/19 18:39:15 DEBUG : pacer: low level retry 1/10 (error googleapi: Error 403: User Rate Limit Exceeded. Rate of requests for user exceed configured project quota. You may consider re-evaluating expected per-user traffic to the API and adjust project quota limits accordingly. You may monitor aggregate quota usage and adjust limits in the API Console: https://console.developers.google.com/apis/api/drive.googleapis.com/quotas?project=202264815644, userRateLimitExceeded)
2019/08/19 18:39:15 DEBUG : pacer: Rate limited, increasing sleep to 1.393625735s

And so on.

Can you try the latest beta?

Same error, unfortunately. I think it may be related to this error, which I didn't find earlier - Team Drive to My drive not copying files

For server-side copies or moves, you need to authenticate with credentials that have access to both the source and destination with the appropriate permissions (preferably Manager)

1 Like

I have the same issue.

I'm user of a teamdrive as commenter, and I have a team drive with 10 members, all managers.

I can't server side copies bewteen the user that has access to the teamdrive and others users in my teamdrive.

I managed to copy like 100 files and then it started erroring out, which is weird because teamdrive permissions are standard so how can I copy some files but not others?

To clarify on rclone I have commenter: remote and user1: remote, which are both teamdrives

No one knows for sure how exactly how these permissions work with respect to the API. The best results are obtained when you have manager permissions on both the source & destination for the same set of users.

Also, you cannot copy server-side from 1 user which has access to another set of users which don't have access. Thats simply isn't how server-side copies work.

I copied over 12 TB that way before it stopped working.

The way I see is the source remote commenter: has read access to the source, and is uploading to user manager: in another teamdrive, where also the commenter is a manager

I suspect you ran out of server side copy quota maybe?

No because I tried many days after and had the same issue.

Almost made me think it was a security fail from google from letting me server copy lol