Rclone double copying data to google drive

Data is getting copied twice to 2 different destinations. I am new to rclone and am not sure if I am just not understanding how to format the command. But it is creating the files in the destination directory. But also in the destination directory, it is creating a 2nd set of directories "/googledrive/appbackup/adminhtml" and then copying the files there as well. What am I doing wrong?

rclone v1.64.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-86-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.3
  • go/linking: static
  • go/tags: none

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /var/www/html/ googledrive:/appbackup/adminhtml/

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
scope = drive
token = XXX
team_drive =

I am copying all contents of the source to the dest.

I see all the data get copied, but then it creates additional folder structure and copies the files there also.

I expect to see this structure


but I am getting this. I don't know why it's copying the files twice and why it' building the googledrive/appbackup/adminhtml path and putting files there.

             ->files (desired result)
                                 -> another copy of files

example showing the files are copied twice.

ubuntu@sqlserver:~$ rclone ls googledrive:/appbackup/adminhtml/ | grep qcreate.php
     7637 qcreate.php
     7637 googledrive/appbackup/adminhtml/qcreate.php
ubuntu@sqlserver:~$ rclone ls googledrive: | grep qcreate.php
     7637 appbackup/adminhtml/qcreate.php
     7637 appbackup/adminhtml/googledrive/appbackup/adminhtml/qcreate.php

try with:

rclone copy /var/www/html/ googledrive:appbackup/adminhtml/

I tried that command with the same result. Data is being copied twice.

Once to the root of /appbackup/adminhtml, then again in /appbackup/adminhtml/googledrive/appbackup/adminhtml/

ubuntu@sqlserver:~$ rclone copy /var/www/html/ googledrive:appbackup/adminhtml/
ubuntu@sqlserver:~$ rclone ls googledrive: | grep index.php
     2112 appbackup/adminhtml/index.php
     1480 appbackup/adminhtml/4-tests/fixvsindex.php
     2112 appbackup/adminhtml/googledrive/appbackup/adminhtml/index.php
     1480 appbackup/adminhtml/googledrive/appbackup/adminhtml/4-tests/fixvsindex.php

That looks lke you had a typo when you ran it before.

Best to start fresh.

rclone ls googledrive:somefolder
rclone copy /var/www/html googledrive:somefolder -vv --log-file /tmp/somelog.txt

rclone ls googledrive:somefolder | grep index.php

Log files are the key as they show you and us what's going on.

So I think I figured out what happend. Although I do not know why. it seems rclone created a googledrive folder with a copy on the source folder. and that is the folder that is being synced.

ubuntu@sqlserver:/var/www/html$ ls -lah | grep googledrive
drwxrwxr-x  3 ubuntu   ubuntu   4.0K Oct 20 05:33 googledrive

Any idea why it created a copy on my source ??? the googledrive folder did not exist on my source until I ran rclone.

Because you had a typo somewhere.


So I deleted the googledrive folder from my source and redid the copy operation. It completed successfully. I somehow must have inadvertently created a copy somehow on the source. I am new, so maybe one of the first copy commands I ran was formatted incorrectly.

Root cause = Me being a NOOB.

Thank you for your help.

The usual reason for this is forgetting the : in the destination which makes it point to a local directory.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.