Rclone does not update mod-time on destination

What is the problem you are having with rclone?

I copied all files through smbclient to the destination. As this did not preserve the mod-time I decided to use rclone to correct this. If the destination does not contain the files the mod-time of all files is set correct, but if they already exist, their mod-time is not updated altough I do not set --size-only or --no-update-modtime?!

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: linux/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)


Which cloud storage system are you using? (eg Google Drive)

Unsecure FTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vv sync ds1618:/simone/ /mnt/user/Simone/

A log from the command with the -vv flag

2020/04/24 07:16:01 DEBUG : Fotograf/Hochzeit-93.jpg: Sizes identical
2020/04/24 07:16:01 DEBUG : Fotograf/Hochzeit-93.jpg: Unchanged skipping

mod-time of the file on the src:
2019-07-14 00:04

mod-time of the file on the dst:
2020-04-23 16:43

hello and welcome to the forum,

"FTP does not support modified times. Any times you see on the server will be time of upload"


Thank you for your answer, but this is not correct. The first files were present on the destination (uploaded through smbclient) and the second are uploaded through rclone:

While uploading the files all files get the server date, but after uploading rclone overwrites the mod-time. I saw that for huge files.

Perhabs a new feature?

How did you upload them? Rclone definitely doesn't support setting ModTime's with FTP, so I'm guessing you uploaded them a different way.

I used the above command. One moment. Will remove the folder again...

Same result:

Configuration (two different ftp logins):

rclone config
Current remotes:

Name                 Type
====                 ====
ds1618               ftp
synology             ftp

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config

As I installed it through an Unraid Plugin: Maybe an additional feature of the plugin?

Oh I see, you are copying from FTP to local. Rclone will preseve times that are set on the FTP server when it reads stuff to local disk. However it can't set times on the FTP server when copying the other way - there isn't a standard FTP command to do that though there are quite a few alternatives rclone could use if it was important!

1 Like

Ok, but why does rclone not overwrite the date or check the date of the local files? Isn't this a bug?

At the moment I'm using SFTP, but I hoped I could use unsecure FTP for a faster transfer (less cpu load / no overhead).

I think about mounting the source as smb share to avoid the overhead:
mount -t cifs -o credentials=/etc/smb-credentials //SMB_IP/share /mnt/smb_share

But I'm not sure if this really speeds up the transfers. EDIT: Ok, shouldn't be a real difference.

If the remote doesn't support modification times then rclone won't use that info in syncing.

FTP is one of the really early interent protocols and it is quite primitive in comparison to SFTP!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.