Rclone docker volume plugin not polling

What is the problem you are having with rclone?

I am trying to use the rclone docker volume plugin to mount a remote Google drive as the consumer folder for a local paperless ngx instance.

Here is a trimmed down version of my docker-compose, leaving out all unnecessary parts (like db and redis):

services:
  paperless-webserver:
    image: ghcr.io/paperless-ngx/paperless-ngx:latest
    volumes:
      - ./paperlessdata:/usr/src/paperless/data
      - ./paperlessmedia:/usr/src/paperless/media
      - consume:/consume
    env_file: docker-compose.env

  paperless-consumer:
    image: ghcr.io/paperless-ngx/paperless-ngx:latest
    volumes:
      - ./paperlessdata:/usr/src/paperless/data
      - ./paperlessmedia:/usr/src/paperless/media
      - consume:/consume
    env_file: docker-compose.env
    command: ["document_consumer"]

volumes:
  consume:
    driver: rclone
    driver_opts:
      remote: "gdrive:consume"
      allow_other: "true"
      vfs_cache_mode: "full"
      log-level: DEBUG
      poll_interval: 10

When starting the file system with docker compose up, the files located in the drive are correctly mounted and paperless is starting to consume the files (i can see in the task log on the paperless GUI and in the logs)

However, when adding new files to the drive, those files are not synchronized.

The setup guide (Docker Volume Plugin) explicitely disables the poll interval, but I tried to omit the poll_interval altogether, hoping for the default to kick in and explicitly setting it to 10 - both did not work.

Upon adding new files to the google drive, those files will never make it to the consume folder. Why?

Run the command 'rclone version' and share the full output of the command.

I doubt it is really relevant, but here you go:

rclone v1.65.2
- os/version: linuxmint 21.2 (64 bit)
- os/kernel: 6.5.0-1011-oem (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.21.6
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google drive

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[gdrive]
type = drive
client_id = 451040569...7k7ir.apps.googleusercontent.com
client_secret = GOC...RjMdixiFt
scope = drive
token = {"access_token":"ya29.a0Ad....jU8SARMSFQHGX2MiwgtB-CJQVM36HAYVu-C7Og0173","token_type":"Bearer","refresh_token":"1//098Ah4jLe_aXLCgYIARA-....Q9DRcihCXU","expiry":"2024-03-26T15:14:09.996577874Z"}
team_drive = 

A log from the command that you were trying to run with the -vv flag

I honestly dont know where to find these logs...

Any help much appreciated! :slight_smile:

welcome to the forum,

perhaps that should be log_level

need to use a log file. something like
log_file: /path/to/rclone.log

@asdffdsa thanks for the reply!

I indeed oversaw the dash for the underscore. I fixed that issue and added the log_file:

volumes:
  consume:
    driver: rclone
    driver_opts:
      remote: "gdrive:consume"
      allow_other: "true"
      vfs_cache_mode: "full"
      poll_interval: 10
      log_level: DEBUG
      log_file: /var/lib/docker-plugins/rclone/rclone.log

however, there is no log file created in the specified directory