Rclone Docker Mount

Hi Guys,
it`s my first post here. I tried to configure rclone for 3 days now and I am a bit desperated, maybe you can help me.
I have a Synology D920+ and want to mount my GDrive (encryted) for my Media. So I run Docker Compose I found on this site:
https:// forum.rclone .org/t/how-to-set-up-rclone-webgui-server-as-a-docker-container/14330/17

So, the config and the GUI work. I can browse on my gdrive (on Web GUI) and add folders and stuff. I checked out on my Windows PC and it worked well with both but now I want to mount a drive on my Synology.

So in my docker compose you can see I added /volume1/Media/PlexMedia
at /data. So I tried both commands (this in docker and after the one in the command line) to mount it but it still won`t work.

Also a mount in the GUI doesn`t work for me.

Anybody can help me please?

Thank you!

Docker Compose:

    image: rclone/rclone
    container_name: rclone_standalone
    restart: always
      - /volume1/docker/rclone:/config/rclone
      - /volume1/docker/rclone/cache:/home/plex/.cache/rclone/webgui
      - /volume1/Media/PlexMedia:/data:shared
      - /etc/passwd:/etc/passwd:ro
      - /etc/group:/etc/group:ro
      - SYS_ADMIN
      - SETPCAP
      - MKNOD
      - /dev/fuse:/dev/fuse
    command: "mount PlexMedia: /data --allow-non-empty --buffer-size 256M --dir-cache-time 1000h --poll-interval 15s --timeout 1h --rc --rc-web-gui --rc-addr :5572 --rc-user=plex --rc-pass=plexmedia"
      - 5572:5572
      - seccomp:unconfined
      - PHP_TZ=Europe/Berlin
      - PUID=1030
      - PGID=100

What is the problem you are having with rclone?

I use rclone in docker with WebUI. I can not mount my gdrive on my host machine (Synology DS920+)

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

DSM7 RC with Docker

Which cloud storage system are you using? (eg Google Drive)

Google Drive Shared Folder

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount --allow-other --vfs-cache-mode full --dir-cache-time 12h --cache-chunk-total-size 128M --vfs-cache-max-age 12h --vfs-read-chunk-size-limit 256M --buffer-size 64M --vfs-cache-max-size 500G PlexMedia: /data --allow-non-empty --buffer-size 256M --dir-cache-time 1000h --poll-interval 15s --timeout 1h --rc --rc-web-gui --rc-addr :5572 --rc-user=plex --rc-pass=plexmedia

The rclone config contents with secrets removed.

type = drive
client_id = XXX.apps.googleusercontent.com
client_secret = secret
scope = drive
token = {"access_token":"ya29.a0AfH6SMDYA3eZObB9VpMH5hHTmh1H4y1iOpLIYVz_kYjjcJq6eo6wP3EtD9R1lbFR5BGWKhAWBdxAp1V13wrgnlh-PZ4ROU87lpxKhDXzSrCFURz2eD1fLI2mATkBFq8JxE-_osWqD6CpqZkxOUYo500AcA_JMQ","token_type":"Bearer","refresh_token":"1//09kyCFjxCRWx8CgYIARAAGAkSNwF-L9IrhofukAKZhSBZLfZzhQsPlaQ0WTUbMjOUmenFUwi88NDT0qUkLPGXPMPv_SF0MjUB1d0","expiry":"2021-06-02T22:20:05.201191857Z"}
team_drive = secret
root_folder_id = 

type = crypt
remote = gdrive:/PlexMedia
filename_encryption = standard
directory_name_encryption = true
password = secret
password2 = secret2

A log from the command with the -vv flag

2021/06/02 21:46:13 ERROR : Error reading tag file at /root/.cache/rclone/webgui/tag 
2021/06/02 21:46:13 NOTICE: A new release for gui (v2.0.4) is present at https://github.com/rclone/rclone-webui-react/releases/download/v2.0.4/currentbuild.zip
2021/06/02 21:46:13 NOTICE: Downloading webgui binary. Please wait. [Size: 4740206, Path :  /root/.cache/rclone/webgui/v2.0.4.zip]
2021/06/02 21:46:14 NOTICE: Unzipping webgui binary
2021/06/02 21:46:14 NOTICE: Serving Web GUI
2021/06/02 21:46:14 NOTICE: Serving remote control on http://[::]:5572/
2021/06/02 21:46:14 ERROR : Failed to open Web GUI in browser: exec: "xdg-open": executable file not found in $PATH. Manually access it at: http://plex:plexmedia@[::]:5572/?login_token=cGxleDpwbGV4bWVkaWE%3D

Thank you so much!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.