Rclone crypt seems not to crypt content of files

I'm experimenting with crypt in a raspberrypi.
the config is:

type = crypt
no_data_encryption = false
password = 1
password2 = 2
remote = SFTPB:/

everything works fine. If I copy a file, it lands ok on destination with a crypted name, but if I do look inside the file on the destination side, the content is plain and readable (I've transferred a text file).

I'm doing something wrong?

hello and welcome to the forum,

when you posted, there was a template of questions, none of which you answered.
help us to help you and post the answers to all questions.

Sorry about that, newbie.

What is the problem you are having with rclone?

it does not encrypt the content of files, just names

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: raspbian 10.11
  • os/kernel: 5.10.63-v7l+ (armv7l)
  • os/type: linux
  • os/arch: arm
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

SFTP and Crypr

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I have mounted the drive using the webgui and I use cp from command line

cp text.txt /media/crypt

The rclone config contents with secrets removed.

type = sftp
host =
pass = 1
port = 22
user = 1
md5sum_command = md5sum
sha1sum_command = sha1sum

type = crypt
no_data_encryption = false
password = 1
password2 = 1
remote = SFTPB:/

the log states:
text.txt: Copied (new)

on the destinaion disk I see I file named vn6aefvqa9ivuhbutki8q63h74 and the content is 12345, so it's not encrypted.

You've turned of data encryption so that would be expected.

Crypt (rclone.org)

that flag is confusing, double negative.
i think you got it wrong.


    Encrypt file data.

actually the manual say the opposite:

  • Examples:
    • "true"
      • Don't encrypt file data, leave it unencrypted.
    • "false"
      • Encrypt file data.

anyway with either options, the content of the file is always 12345.

Is this a bug?

i woud remove that flag, as false is the default value.

again, when you posted, there was a template of questions, most of which you did not answer.

add -vv to your command, copy a single file, post the entire log.

I think you had it flipped when you copied it to true.

Please repeat the copy process and validate and share the full debug logs.

etexter@seraphim rclone % rclone ls SFTPC:
etexter@seraphim rclone % rclone ls SFTPC:
etexter@seraphim rclone % rclone copy /etc/hosts SFTPC:
etexter@seraphim rclone % rclone ls SFTPC:
      366 hosts


type = sftp
host =
user = felix
pass = password
md5sum_command = md5sum
sha1sum_command = sha1sum

type = crypt
remote = SFTP:crypt
password = password
password2 = password
no_data_encryption = false
felix@gemini:~/crypt$ cat ohsrrdmahvjdj7oclj1uhhfkmg
�wi��   Ԥ��ӵr��į��(��� ܛ�V¶���<�
     ��4`�սAds7I����?2\��v�n_"�ڞ�֤���5h}-��GmFk���n��K��jx�%2����B(��E����6�ň�bG����J&��b��v� �9�">	IMv�@NUE,x$���S�w&g��u@޽��+ow)
��ќCBIKT��	��F.��!x���C�8v��Y�2�wdH�Bë�S�G��@D���

Nah, I made a typo when I was typing and hit enter too early so it was written incorrectly and I don't want to edit it and make it more confusing.

Yeah, typo as I hit enter too early on something and I don't like editing posts to confuse folks.

Typo in my post as I hit enter too early. Thanks though.

Ok not we're making progess.
If I do the command you suggested, it works.
So I digged up.
If I do mount manually the drive with
rclone mount SFTPBC: /media/crypt -vv
it works

The issue/bug it is related to the webgui
If I do mount the drive using webgui it seems it does not carry the "no_data_encryption = false" options

so thanks for me issue is solved, but I guess there is a bug somewhere

Details are helpful.

if you can include steps, screenshots of what you are doing and the output, that's what we need to figure out what the problem is.

What WebGUI are you talking about?

as false is the default value, there should be nothing to carry over

can you try my suggestions, remove no_data_encryption = false and test

Ok @asdffdsa, I've removed the option and it works even from a webgui mount.
So there should be a stange bug in the webgui that when the options is present it will turn it off.

Again, what WebGUI? What log? What screenshot? What are you doing?

ok, good.
if this a rclone bug, we need to find it.
if you can answer @Animosity022, that would be most helpful to us.

Some extra background.
I'm using the webgui option. I launch wth
rclone rcd --rc-web-gui --rc-user user --rc-pass pass --rc-addr= --allow-other
then I do everything from there. It says gui version v1.57.00
I've created the config from there and then I use the Mounts section to create a mount.
No command line stuff until instructed here