Rclone crypt created a duplicate bucket folder when copying from a shared google drive

This is a bit weird and I am not sure it is a bug, but it gave me a heart attack!

Using the Google drive web interface, I added a shared folder to my drive, then tried to use rclone to copy from the shared drive to my encrypted rclone bucket.

The result was that rclone created a second, duplicate bucket folder which I could see in the Google Drive web gui as two separate folders named bucket.

I fixed it by renaming the new bucket to bucket_2020

rclone command: rclone -v copy --drive-shared-with-me gdrive_api:Kids_TV/ gdrive_api_crypt:Kids_TV/

rclone config:

    type = drive
    client_id = <SNIP>.apps.googleusercontent.com
    client_secret = <SNIP>
    token = {"access_token":"SNIP","token_type":"Bearer","refresh_token":"SNIP","expiry":"2020-09-20T18:33:39.8828479+08:00"}
    root_folder_id = <SNIP>

    type = crypt
    remote = gdrive_api:bucket
    filename_encryption = standard
    password = <SNIP>
    password2 = <SNIP>

That's a known issue.

Good to know. Thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.