Rclone copy takes longer in another docker image

What is the problem you are having with rclone?

I am running rclone copy for copy files from Google bucket to Azure storage account more than 3 months. rclone is configured in Azure DevOps agent pool. Now there is requirement to move solution to another agent pool. When I tried to run rclone to new Agent pool, it takes more than 3 hours whereas same job is taking 1 hour to complete in existing agent pool.

I check reclon version which is 1.52 on both agent pool and has same amount of RAM available.
I also tried updating rclone with latest version i.e. 1.54, no luck. Important thing is both agent are able to execute the job successfully. I am only worried how can I troubleshoot this issue to know why it is taking more time in new Agent pool? Any pointer?

You'd probably want to fill out the Help and Support template and capture logs to see what's going on.

I'd guess network bandwidth, or resource contention in the agent pool.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.