Rclone copy -P refresh time

What is the problem you are having with rclone?

I used the rclone copy -P command, because the bot I set cannot hold too much information, so I need to change the -P progress display refresh time. The default value is 500ms. If I want to set it to 2000ms, what should I do?

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)


Which cloud storage system are you using? (eg Google Drive)

google drvie

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy -P

Paste command here

rclone copy gc:{} gc{} -P -q

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

perhaps this can help


default value 1m?
rclone copy --stats =1m
Some tasks are over before refreshing twice,
rclone copy -q -P --stats =0.5m,Can it be set like this???

why not try it yourself and see what happens.

perhaps you might use a log file

I need its real-time speed progress to be displayed in the bot, but my programming ability is not enough, it will not be extracted

have you read this?

"This can be used with the --stats-one-line flag for a simpler display."

-P --stats-one-line -stats 0.2m,it's ok,thank you

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.