Rclone copy for S3 with wildcards

What is the problem you are having with rclone?

I need to look for a file in S3 by passing wildcards using rclone.. An example of the file is "PK_System_JAN_22.zip". Month and year keep changing. Hence I should be looking up in S3 with something like PK_System_???_??.zip. If I was to run a command on S3, it would like like this - aws s3 cp s3://bucket/folder1/folder2/ /destinationFolder --recursive --exclude * --include PK_System_???_??.zip. Can someone let me know what should be the rclone command to achieve this.
I tried doing this and it didnt work as expected - copy s3://bucket/folder1/folder2 destinationFolder --include PK_System_***_**.zip}

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

copy s3://bucket/folder1/folder2 destinationFolder --include PK_System_***_**.zip`

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

always best to test filters using rclone ls, not rclone copy

rclone ls . --include="PK_System_???_\d\d.zip"

1 Like

This should be something like what you wanted

rclone copy s3:bucket/folder1/folder2 destinationFolder --include "PK_System_*_*.zip"

Add --dry-run to see what rclone would copy first.

1 Like

was there something wrong with the filter i suggested --include="PK_System_???_\d\d.zip"

Looks better than mine. Our answers crossed in the post so I didn't see your reply when I was writing mine.

Edit or looking at the timestamps, I just missed it - sorry!

Thank you for the solution..

Thank you. this worked!

1 Like

I need to look for a file in S3 by passing wildcards using rclone.. An example of the file is "PK_System_JAN_22.zip". Amazon S3 Storage Providers. The S3 backend can be used with a number of different 192.168.l.254 providers: AWS S3 Home Config; Alibaba Cloud (Aliyun) ...Re: Restart network without reboot. Sun Apr 20, 2014 10:48 am. service networking restart. This will restart all the network interfaces.
What i am trying to do is copy or move folders from one drive to the other, seems simply but i cant get any form of wildcard to work.

hello and welcome to the forum,

this topic has been solved.

best to start a new topic, answer all the questions in the help and support template

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.