Rclone Configuration Improvement

Hi, I am running rclone under docker and working perfectly fine and I added number of options in configuration file to make it a lot better but I think this one still needs lot of attention and I know I will find the best solution here.

Currently my setup is NUC with 8GB RAM, 1TB SSD and Ubuntu 18.04 LTS running Plex and Rclone and nothing else.

This is my compose

    image: ghcr.io/hotio/rclone:release
    hostname: ${DOCKERHOSTNAME}
    container_name: rclone
      - RCLONE_CONFIG=/config/rclone.conf
      - apparmor:unconfined
      - SYS_ADMIN
      - /dev/fuse
      driver: json-file
        max-file: ${DOCKERLOGGING_MAXFILE}
        max-size: ${DOCKERLOGGING_MAXSIZE}
    restart: unless-stopped
      - /mnt/gdrive:/mnt/gdrive:shared
      - ${DOCKERCONFDIR}/rclone:/config
    command: mount "gdrive:"  "/mnt/gdrive" --allow-other --uid "1000" --gid "1000" --umask "022" --rc --rc-addr localhost:5572 --rc-no-auth --drive-skip-gdocs --fast-list --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 2048M --buffer-size 64M --poll-interval 1m --dir-cache-time 168h --timeout 10m --drive-chunk-size 64M

I think I can utilise cache option or something else you guys recommend to make it much better as I have SSD and nothing installed on it except Plex and Rclone.

Thank you

if there something specific that is not working well?

--fast-list does nothing on a mount

Basically most of my stuff is from here :slight_smile: homescripts/rclone.service at master ยท animosity22/homescripts (github.com) except few bits I picked it up from here an there. I just added --fast-list this morning but I will remove it. I thought --fast-list help out with folder structure.

yes, that is the best place.

if you are not having a specifc problem, what is it that you need help with?

I read so much about using cache but not sure if its really required for my setup :blush:

you would need to add a --vfs-cache-mode to enable the cache.
why not you can add the cache and see if it makes a difference?

i do not use --vfs-cache-mode and i do not use the cache

Okay I added it and lets see :slight_smile:

--vfs-cache-mode full --cache-dir=/cache

mouzzampk2014 Hassan, What DockerHub image did you use as your baseline? Was it by chance the rclone/rclone image or did you build it from Alpine or a different distribution?

Hi Allen, I am using this image. Its very well maintained image: ghcr.io/hotio/rclone

Thanks. I use base Alpine for executable; I use the golang image when I need to compile go programs.

Glad to hear there are some other choices