Rclone.config not found when baseimage is used to create virtual desktops. Basically trying to use rclone in VDI infrastructure

What is the problem you are having with rclone?

I installed and configured the rclone with MS Blob storage accountname and keys in 1 of my base image which going to be used to create virtual desktops. The configuration was successful and I was able to mount the blob storage by running "rclone mount" command.

But when i used this baseimage to create set of virtual desktops and logged into 1 desktop and ran the "rclone mount" command and got this error:

Notice: Config file "C:\\Users\\ankur.vishwakarma\\Appdata\\roaming\\rclone\\rclone.config" not found - using default
Time stamp Failed to create file system for "<filesystemname>:<blobname>": didn't find section in config file

Reference wiki I used to configure rclone for my environment : http://blog.51sec.org/2021/11/mount-azure-blob-storage-into-local.html

Run the command 'rclone version' and share the full output of the command.

I am sorry, copy paste from the VDI is blocked hence I took the screenshot of the error and version and uploaded here.

Which cloud storage system are you using? (eg Google Drive)

Microsoft Azure Container

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount remote:path/to/files C:\myPath

The rclone config contents with secrets removed.

rClone config contains the storage account name and access key. Hence not able to share here.

A log from the command with the -vv flag

Paste  log here

It looks like the rclone config is missing from the image.

rclone config file

will show you where the config file is. Check the original and the image. It is a text file you can look at in an editor (like notepad).

Is it possible to set the rclone.config file location somewhere else instead of roaming profile folder so that once the image convert to desktop the config file stay where it was located?

Use the flag:

      --config string                        Config file (default "$HOME/.config/rclone/rclone.conf")

Point to where you it is.

1 Like

Is this tag used to set the default location of the config file while configuring the rclone?
So the syntax would be:

rclone config --config c:\<Any Path>

Is the above syntax right to place the config to C: drive?

Yes, give it a try and validate it.

So I created new config file which went to windows default location i.e. user's roaming profile (C:\Users<user.name>\AppData\Roaming\rclone\rclone.config)
I copied the file to my desired location C:\ProgramFile\rclone

Then i ran command:

rclone config --config c:\programfile\rclone\rclone.config

Then I ran the command "rclone config file" and it show me the default location as new location i.e. c:\programfile\rclone\

I am now trying to pack this VM to base image and then will convert this base image to 2 or 3 desktops to check if rclone work to mount my Blob container in windows.

Thank You.

It is working fine now after changing the default path of config file.

Many thanks to all for your replies. :slight_smile:

1 Like