Rclone config create - teamdrive ID not passed in beta v1.56.0-beta.5531.41f561bf2

What is the problem you are having with rclone?

When using rclone config create - the teamdrive ID is not passed to the config file in beta, but does work in stable (v1.55.1).

What is your rclone version (output from rclone version)

rclone --version
rclone v1.56.0-beta.5531.41f561bf2
- os/version: debian bullseye/sid (64 bit)
- os/kernel: 5.12.9-xanmod1 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.4
- go/linking: static
- go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

OS: Pop!_OS 21.04 x86_64
Kernel: 5.12.9-xanmod1
Shell: zsh 5.8

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config create testy drive scope drive server_side_across_configs true team_drive abc123 service_account_file /opt/sa/123.json   
--------------------
[testy]
type = drive
scope = drive
server_side_across_configs = true
team_drive = 
service_account_file = /opt/sa/123.json
--------------------

The rclone config contents with secrets removed.

[testy]
type = drive
scope = drive
server_side_across_configs = true
team_drive = 
service_account_file = /opt/sa/123.json

A log from the command with the -vv flag

<7>DEBUG : rclone: Version "v1.56.0-beta.5531.41f561bf2" starting with parameters ["rclone" "config" "create" "testy" "drive" "scope" "drive" "server_side_across_configs" "true" "team_drive" "abc123" "service_account_file" "/opt/sa/123.json" "-vv"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Using config file from "/home/max/.config/rclone/rclone.conf"
<7>DEBUG : Saving config "server_side_across_configs" = "true" in section "testy" of the config file
<7>DEBUG : Saving config "team_drive" = "abc123" in section "testy" of the config file
<7>DEBUG : Saving config "service_account_file" = "/opt/sa/123.json" in section "testy" of the config file
<7>DEBUG : Saving config "scope" = "drive" in section "testy" of the config file
<7>DEBUG : testy: config in: state="", result=""
<7>DEBUG : testy: config out: out=&{State:teamdrive Option:<nil> OAuth:<nil> Error: Result:}, err=<nil>
<7>DEBUG : testy: config in: state="teamdrive", result=""
<7>DEBUG : Auto confirm is set, choosing default "false" for state "teamdrive_ok", override by setting config parameter "config_change_team_drive"
<7>DEBUG : testy: config out: out=&{State:teamdrive_ok Option:<nil> OAuth:<nil> Error: Result:false}, err=<nil>
<7>DEBUG : testy: config in: state="teamdrive_ok", result="false"
<7>DEBUG : Saving config "team_drive" = "" in section "testy" of the config file
<7>DEBUG : testy: config out: out=<nil>, err=<nil>
--------------------
[testy]
type = drive
server_side_across_configs = true
team_drive = 
service_account_file = /opt/sa/123.json
scope = drive
--------------------
<7>DEBUG : rclone: Version "v1.56.0-beta.5531.41f561bf2" finishing with parameters ["rclone" "config" "create" "testy" "drive" "scope" "drive" "server_side_across_configs" "true" "team_drive" "abc123" "service_account_file" "/opt/sa/123.json" "-vv"]

I also see another issue, the date/time information before DEBUG: is printed as <7>.

I have the same issue in this GitHub action, but has been unable to reproduce it.

Can you give some more details about your setup? I am especially curious to know how you got system logging activated. Is rclone (also) running as a service?

Hi Ole, I am just rehashing a mountscript and testing on a laptop with PopOS. Happy to answer any questions you might have. There is nothing more to the logging than using the very verbose flag.

Run the command with -vv flag added.

rclone command options -vv

I have not been able to test yet on ubuntu 20.04 LTS but intend to when I get a chance.