Rclone config create miss some info and doesn't work as expect

What is the problem you are having with rclone?

Wrong or missing some part of rclone.conf

What is your rclone version (output from rclone version)

rclone v1.53.3

  • os/arch: linux/amd64
  • go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

CentOS 7 x64

Which cloud storage system are you using? (eg Google Drive)

Microsoft OneDrive business

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config create OneDrive onedrive

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":secret"}

A log from the command with the -vv flag

2020/12/14 17:21:13 DEBUG : rclone: Version "v1.53.3" starting with parameters ["rclone" "config" "create" "OneDrive" "onedrive" "-vv"]
2020/12/14 17:21:13 NOTICE: Config file "/home/black/.config/rclone/rclone.conf" not found - using defaults
Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine
Auto confirm is set: answering Yes, override by setting config parameter config_is_local=false
2020/12/14 17:21:13 DEBUG : Starting auth server on
If your browser doesn't open automatically go to the following link:
Log in and authorize rclone for access
Waiting for code...
2020/12/14 17:21:17 DEBUG : Received GET request on auth server to "/"
Got code
2020/12/14 17:21:17 DEBUG : OneDrive: Saved new token in config file
2020/12/14 17:21:17 DEBUG : Closing auth server
2020/12/14 17:21:17 DEBUG : Closed auth server with error: accept tcp use of closed network connection
2020/12/14 17:21:17 DEBUG : Using default permissions for config file: -rw-------
type = onedrive
token = {"access_token”:”secret”}
2020/12/14 17:21:17 DEBUG : rclone: Version "v1.53.3" finishing with parameters ["rclone" "config" "create" "OneDrive" "onedrive" "-vv"]

Hi folks,

I'm trying to get some script to automate config procedure of rclone because I have to set a lot of Microsoft OneDrive business account, unfortunately I've some problem while using rclone config create because it works great and fully configure my remove on Microsoft OneDrive business, I'm able to login into my organisation auth page and get also the token, but when I try to use rclone after this I get:

Failed to create file system for "OneDrive:": unable to get drive_id and drive_type - if you are upgrading from older versions of rclone, please run `rclone config` and re-configure this backend

So I tried to use rclone config and do every step by hand and I get a different rclone.conf because in this way I had also 2 lines:

drive_id = long long secret id
drive_type = business

In this manner, rclone works great as I expect.

Am I missing something ?

I also tried to fill the answers to rclone config with echo y or printf y\n and similar, I get an error with: Failed to read line: EOF

I hope that someone is able to help me or figure some solution, really thanks in advance.

Unfortunately the automated process doesn't put the drive_id and drive_type in yet.

You can add them as parameters to the rclone config create if you know them.

This is something we are working on

Ok so many thanks for help. My only concern it was about getting the drive_id in my case (business) and effectively is a bit challenging through Microsoft Graph but I figure it out.
Congrats for your very powerful software!!!

Thank you! We plan to fix this, I just haven't figured out how yet!

The problem is that the same interface is used for manual and programmatic configuration and the asking questions bit doesn't work well via a program.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.