Rclone config create couldn't decrypt password | SOLVED

//EDIT The problem was solved using Obscure, thanks to @B4dM4n for the solution


I am trying to create a new remote using rclone config create REMOTE webdav vendor "nextcloud" user "Username" pass "password" url "https://....../webdav/"

However, there is an issue with the password. when I try to run rclone ls REMOTE:/ i get this error:

Failed to create file system for "EBC:/": couldn't decrypt password: base64 decode failed when revealing password - is it obscured?: illegal base64 data at input byte 14

I have tried encoding the password to base 64 and I am still getting the same error.

also when I edit the password through the rclone config it works as intended.

Any help would be great.

Thanks in advance.

thought maybe --crypt-password would help but no ( i assume this is the key for encrypting uploaded files)

edited mistakes in question :slight_smile:

Anyone any ideas as i haven’t a clue?

To specify the password on the command line, it probably has to be obscured first.
The rclone config command seems to only do this automatically when used in the interactive mode.

1 Like

Perfect just what i needed :slight_smile: :slight_smile: