Rclone command as a service in windows task scheduler only run when user is logged on

rclone command as a service in windows task scheduler only run when user is logged on, I am facing issue that if server restart my drive should automatic connected using this below task scheduler

$time = New-ScheduledTaskTrigger -AtStartup
$action = New-ScheduledTaskAction -Execute PowerShell.exe -Argument '-WindowStyle Hidden -Command "rclone mount aws_s3_test:test-136 S: --vfs-cache-mode full"'
$setting = New-ScheduledTaskSettingsSet -ExecutionTimeLimit 0
Register-ScheduledTask -TaskName "S3_Sync" -Action $action -RunLevel Highest -Trigger $time -Settings $setting
Start-ScheduledTask -TaskName "S3_Sync"

but here after using this when my server restart I have to login into server and then the drive is attaching

Please help
Thanks in advance !

it's just for checking the logs, right ? or it's a solution


Can you please tell me how to auto-mount S3 on a local laptop? I very need this.
Every time I close PowerSH, my maped drive is lost.

you can use this, and replace the command or name you want it will create the task scheduler and you will able to do the same

I already tried; how its not working, I don't know. i add manually in task Scheduler but its not working.

i try but not working.

Share me you task scheduler screenshot


I am unable to paste or create folders in the mounted drive; the error log is shown below.

2023/12/20 16:33:51 ERROR : /: Dir.Mkdir failed to create directory: InvalidBucketAclWithObjectOwnership: Bucket cannot have ACLs set with ObjectOwnership's BucketOwnerEnforced setting

    status code: 400, request id: ZWVQEPQJWZXMKYS8, host id: FCcojn/mgUMwANUrCvkwR2MhidPzrNr+UIuOtkurqdKZx5F3yDHStUSssgIW0Lpwn2oqH9AlEaY=

What is the solution for this error.

Do not hijack somebody's else topic with your unrelated problems.

Create new topic - provide ALL information you are asked for by the template.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.