Rclone checks returning md5 differ

Hi, I started one rclone check, but while I was checking it returned me the following warnings, I would like to know why these messages, because the files have not been modified.

2019/08/19 22:41:10 ERROR : Public/xxxxxx/DESKTOP/xxxxx_10062015/xxxxx/xxxx.mov: MD5 differ
2019/08/19 22:53:41 ERROR : Backup/xxxxx/_raid/_xxxxx/Electronics_Backup_xxxx/USERS_xxxxx_10mai2010.rar: MD5 differ

rclone version is what?

rclone remote is what?

What's the full command you are running with -vv and please share the complete log.

rclone -vv not found command

i run rclone -V, show this

rclone v1.38

  • os/arch: linux/amd64
  • go version: go1.9

Your version is a few years old so it would be wise to upgrade it.

https://rclone.org/downloads/

You have to run the full command you had before and add -vv on it.

An example is:

[felix@gemini ~]$
[felix@gemini ~]$ rclone lsd GD:
          -1 2019-08-16 12:02:22        -1 blah
          -1 2019-07-09 13:14:42        -1 gemini
          -1 2017-06-09 09:59:43        -1 media
[felix@gemini ~]$ rclone lsd GD: -vv
2019/08/23 10:07:44 DEBUG : rclone: Version "v1.48.0" starting with parameters ["rclone" "lsd" "GD:" "-vv"]
2019/08/23 10:07:44 DEBUG : Using config file from "/opt/rclone/rclone.conf"
          -1 2019-08-16 12:02:22        -1 blah
          -1 2019-07-09 13:14:42        -1 gemini
          -1 2017-06-09 09:59:43        -1 media
2019/08/23 10:07:45 DEBUG : 5 go routines active
2019/08/23 10:07:45 DEBUG : rclone: Version "v1.48.0" finishing with parameters ["rclone" "lsd" "GD:" "-vv"]
[felix@gemini ~]$

if i upgrade rclone version will gdrive settings be lost?

No, your settings will not be lost.

To update i run apt upgrade rclone ?

How did you install it? What operating system are you running?

You should install it via:

https://rclone.org/downloads/

And follow the instructions.

Using the latest stable is always a good start, and that version is certainly old - so do that before anything.

But assuming that doesn't just make it go away, I wonder if this may be due to uploading via a VFS mount with low cache level. If it can't truncate as expected the checksum might differ even if the contents of the file practically remains the same after upload?

This is mostly just a hunch since I don't know enough about the specifics of how and why rclone truncates files. Do you know @Animosity022 ?

This file is apparently corrupted, or different to the local one. Whether it has changed in drive or on your local disk it is hard to say. Or it could have got corrupted when it was uploaded. Try downloading it then running rclone md5sum on the original, the downloaded copy and the one in the cloud.

When did you upload it? If it was with rclone do you know which version?

I notice one of the files is a rar archive.
rar has internal CRCs to detect corruption separate from anything rclone or the filesystem uses.
I would suggest opening the rar and running "test" on it to see if it actually corrupted in some way. In winrar there is a big button to do this on the main window as you open the archive.

1 Like