Rclone cache shows current data - rclone browser does not?!

Apologies in advance for asking an rclone browser question on the rclone forum, but this is a peculiar problem which I am unable to solve.

'Folder1' is renamed 'Folder2' using the 'Rename' button in rclone browser.

This quickly updates on my rclone mount and shows the new 'Folder2'.

However, when I browse using rclone browser, I still see 'Folder1' instead of 'Folder2' ... a day later.

No idea how/why that is possible if the folder has been renamed and the mount sees the renaming fast. Manually deleting the gdrive and gcrypt cache and db files doesn't help.

My mount is via nssm using the following:
mount --read-only --allow-other --buffer-size 0M --cache-info-age 10m --drive-chunk-size 32M --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --vfs-cache-mode writes --cache-workers=8 --cache-dir "C:\cache_vfs_gcrypt" --cache-db-path "C:\cache_vfs_gcrypt\gcache.db" --cache-chunk-path "C:\cache_vfs_gcrypt\gcache" gcrypt:/ X: --config "H:\rclone\rclone.conf"

Any idea why I see old data via rclone browser whilst seeing current data on the mount?

Thanks in advance.


this might not be the problem but is there a reason you are using so many flags?

  • --allow-other does nothing on windows.
  • --vfs-cache-mode writes. your mount is read only, so this flags is not needed.
  • most likely you do not need the cache and vfs flags. i never use them at all.

perhaps simplify your mount and test again.
this is how i do my mounts. can stream 4k videos no problem.
mount gcrypt: x: --read-only --config=h:\rclone\rclone.conf

Thanks for the reply. I modified the nssm mount to see if that was the issue, but using your mount command returns the following error:

H:\rclone>.\nssm start gcrypt
gcrypt: Unexpected status SERVICE_PAUSED in response to START control.

well, i used what you posted.

your command did not have a rclone in front it so i did not add it to mine.
the full command would be.
rclone.exe mount gcrypt: x: --read-only --config=h:\rclone\rclone.conf

i always write a batch file, get that working and then turn that into a service.

Okay, the mount works and I can access and browse the files. But there is a new problem: rclone browser cannot see any folders or files at all ... is it because I am using a cached remote (gcrypt)?

Your mount command isn't referencing the cache, so I'm guessing you aren't caching your remote?

i have never used the cache.
it is a beta feature, is no longer maintained, and will be removed from the next version of rclone.

i always run my rclone mount as system user, try that.

Same error when running rclone mount instead of using nssm: can access the mount, but rclone browser cannot access gcrypt.

Works fine with a slimmed down command:
mount --read-only --cache-dir "C:\cache_vfs_gcrypt" --cache-db-path "C:\cache_vfs_gcrypt\gcache.db" --cache-chunk-path "C:\cache_vfs_gcrypt\gcache" gcrypt:/ X: --config "H:\rclone\rclone.conf"

So I guess I'm stuck with the cache for now?

can you post the config file, removing passwords,client id and what not?

which rclone browser are you using?

i use this

Same rclone browser as you: GUI for rclone, v1.8.0

config is as follows:

[gdrive] type = drive client_id = X client_secret = X scope = drive token = X upload_cutoff = 256M chunk_size = 256M root_folder_id = X

[gcache] type = cache remote = gdrive: chunk_size = 32M workers = 8 info_age = 1w chunk_total_size = 20G db_path = C:\cache_gcrypt chunk_path = C:\cache_gcrypt

[gcrypt] type = crypt remote = gcache:/X filename_encryption = standard directory_name_encryption = true password = X password2 = X

i do not use cache, but

your config is gcrypt->cache->gdrive

perhaps create a new remote gcrypt2->gdrive

That would probably work, but given the enormous amount of data in my gcrypt, I'd rather not risk it - just in case...

I almost had a heart attack when the oauth token expired, so the thought of messing with the config in any way is a scary prospect.

well, i have done this.

  • create a new remote gcrypt2
  • use the same passwords as gcrypt
  • use the same folder on gdrive that gcrypt used

do a rclone ls gcrypt2:, and you would should see your files.

but i understand your concern.

Ahhh, I see what you mean. Basically create a second, non-cached remote to access the old cached gcrypt, thereby circumventing the cache entirely.

Makes sense. Did you notice any improvement in performance after eliminating the cache?

yeah, that does make sense.

i always try to create the simplest command.
if there is a problem, i carefully add flags one at a time.
i have never used that cache, never tried.

as i mentioned, it is beta, has known bugs and has not maintained in a long time.
in 1.52, the cache will be depreciated.
rclone will merge the cache with the vfs.

i also do not use the vfs, sometimes i use --vfs-cache-mode=writes but nothing more.

I guess removing the cache will have certain access time benefits.

Roughly how long does it take for a 2160p film to open using your direct mount method?

using my gcrypt, i start a 2160p in 2 seconds.

instant media server
rclone.exe serve dlna gcrypt: --read-only
open vlc, and point to upnp.


Done - and it works!

Your simplified nssm mount is fast and rclone browser can see exactly the same files as the mount.

Tested it and then renamed gcrypt to gcrypt_old and gcrypt2 to grypt.

Thank you for the help :slight_smile:

glad i could help solve your problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.