Rclone cache errors, possibly due to uploading outside the cache?


#1

okay so I ran:
D:\rclone-v1.41>rclone size -v --fast-list --drive-chunk-size 128M “cleancachecrypt:”

then got:
2018/05/13 03:06:30 ERROR : path/filename: error refreshing object in : in cache fs Google drive root ‘cleancryp
t/126.M:’: object not found

another dozen similar errors
then:
2018/05/13 01:48:21 Failed to size: directory not found

admission: I did get lazy a week ago and upload a dozen or so files outside the cache directly to the crypt… I was hoping though that running the size command would refresh my cache database, but I guess it doesn’t? if this is true how do I refresh the cache database? make the cache check itself and update it’s
cleancache.db
file? without,ya know, just deleting said file?


#2

kill -HUP refreshes the DB.

I think one of the later betas now has a polling fix.


#3

I don’t see HUP or kill here:
https://rclone.org/commands/
https://rclone.org/cache/

can you elaborate please? use some sort of example for the full command?
I don’t assume you mean to tell me to run
rclone kill -HUP -v “cleancachecrypt:”
or do you? it’s hard for me to say since I’m not aware of kill being a valid command…
I should mention I am not using mount in anyway at the moment. I’ve purely used the cache to create a 2gb database file which makes lsd lsl and such commands nearly instant (instead of taking all day).

with no mount running, there’s in theory nothing to kill, which makes me wonder what to do… it doesn’t make much sense that my best option is to start a mount and then instantly kill it… but maybe it is?


#4

It’s just a native OS command for Linux:

kill -HUP 3550

In my case of that screenshot.


#5

not being on linux, and not running a mount, I think maybe kill won’t help me. :-/
I’m on windows, and rclone isn’t running at all, so I doubt kill would have any effect, but like I guessed, I might be able to run a mount, and then kill that mount, which might do the trick… at this point though it might just be easier to wait for my 600hours to expire (that’s what I set the refresh timer to because at the time I was planning to always upload and download within the cache, until I lazily forgot a few times).


#6

You can restart it with a “–cache-db-purge” option. I’m not sure a Windows guy so I’m not sure how to use kill other than cygwin or something like that as it’s been a number of years for me on Linux/MacOS :slight_smile: