Rclone box OATH2 token refresh didn't work for a good hour and then started working again

I found a thread* from a year ago exactly describing the problem I'm having today when I went to refresh my box token.

Have box changed something again or is my local config borked somehow?

*Here's the approximate url:
https:// forum. rclone. org/t/ rclone-box-oath2-now-seems-to-need-you-to-generate-your-own-client-id-and-client-secret/14583

In case it's needed, here's --version
rclone v1.55.1

  • os/type: linux
  • os/arch: amd64
  • go/version: go1.16.3
  • go/linking: static
  • go/tags: none

What error you are getting? Can you share more details?

The error is reproduced below

There seems to be a problem with this app.
Error: redirect_uri_missing 

Show Error Details

    state=<random string>
    client_id=<random string>

Can you share your rclone.conf as well.

The Help/Support template really is useful for reporting an issue as it captures all the details.

Never mind, it started working as soon as someone else wanted to take a look... maybe there was a transient misconfiguration on box:s side?

To be clear, I tried the reconnect things for the fourth time today to be really sure I got the error details for the default case correct and now the refresh worked. shrug

Sounds like the old --magic flag..

Changed the topic so nobody will get directed here by a search engine and get their dreams broken

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.