Rclone being Killed on Raspberry Pi 3 while scanning

What is the problem you are having with rclone?

**I'm trying to scan my library on Plex. I'm using Raspbian on Rapberry Pi 3 Model B. While scanning it would be killed after a while. After it is killed, the drive is still mounted and I have to restart the Pi completely to unmount and then re-mount it. If try to re-mount if without restart it shows me an error,

2020/12/26 21:44:34 Fatal error: Can not open: /home/pi/mnt/rclone: open /home/pi/mnt/rclone: transport endpoint is not connected

What is your rclone version (output from rclone version)

rclone v1.53.3
- os/arch: linux/arm
- go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Latest Raspbian (32-Bit)

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount dropbox:/ $HOME/mnt/rclone --allow-other --dir-cache-time=8700h --attr-timeout 8700h --vfs-read-chunk-size=16M --vfs-read-chunk-size-limit 50M --buffer-size 50M --drive-chunk-size=200M --rc --vfs-cache-mode writes --config "/home/pi/.config/rclone/rclone.conf"


you should be able to unmount without reboot, this does not work?
fusermount -u -z /home/pi/mnt/rclone

i found with my pi, most problems are running out of ram.

Thank you for that unmount command, it worked smoothly.

About that other point, is there any way to limit the RAM use to a specific amount?

tweak this

this might be a good post to read, that i contributed to.

to run the mount without vfs and how to prime the mount for a quick plex scan.
Google Drive, Plex, Windows 10

So I should try to run it with normal cache without VFS involved, right?

I'll check that link. Thank you.

the pi b model has what, 1GB ram, so you got to try to tweak each and every flag.
so running without the vfs might be the way to go.


Yes, 1GB it is. It was just lying around collecting dust, so I decided to use it as a portable storage for my Audiobooks to play via Plex or small videos or TV shows with low bitrates.

good idea,
if you get it working, make sure to update the post.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.