RClone as Windows Service (Running as SYSTEM User) Creates 18GB Log File?!

What is the problem you are having with rclone?

When running via NSSM, my entire hard drive is full to the brim, and an 18 GB log file. I cannot find the RClone cache directory (as the usual one C:/Users/Me/AppData/Local/RClone is empty) to remove the files and troubleshoot.

Run the command 'rclone version' and share the full output of the command.

Yes

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Running as a service via NSSM with SYSTEM user (So both Admin programs and local user can access it)

mount gdrive-media-crypt: X: --allow-other --dir-cache-time 2h --poll-interval 10s --vfs-cache-mode full --vfs-cache-max-size 50G --vfs-cache-max-age 2h --vfs-read-ahead 2G -vv --no-console --log-file C:\RClone\logs\log_file.txt --config C:\RClone\config\rclone.conf

The rclone config contents with secrets removed.

[putio]
type = putio
token = {"access_token":"REDACTED","expiry":"0001-01-01T00:00:00Z"}

[gdrive-media]
type = drive
client_id = REDACTED
client_secret = REDACTED
scope = drive
root_folder_id = REDACTED
token = {"access_token":"REDACTED","token_type":"Bearer","refresh_token":"REDACTED","expiry":"2022-05-06T21:20:47.1388803-04:00"}
team_drive = 

[gdrive-media-crypt]
type = crypt
remote = gdrive-media:/media
filename_encryption = standard
directory_name_encryption = true
password = REDACTED

A log from the command with the -vv flag

The file was too big to even open with Notepad or Wordpad, Word, or to convert to PDF!!!

The simplest way I can describe the issue is that running RClone as a service via NSSM works well for my use case because Acronis (the backup utility) I use will not "see" any RClone drive run on a local user account, nor does it "see" them if I run the account from an elevated cmd prompt. So, after re-reading the documentation, I thought running it as a service under a SYSTEM account (thus making it accessible to ALL users) would work. It did! I was able to run a back up directly to the drive.

However, my 500 GB solid state drive was left with almost 12 GB left!!! It was a little less than half when I originally ran RClone and stepped away for dinner. Now, I cannot find the RClone cache directory, as the usual one from the command prompt run under my user account (C:\Users\Me\AppData\Local\RClone is empty. My drive is still very much full.

Does anyone know where the SYSTEM user in Windows places the RClone cache? Should I re-run with a defined cache directory? Any suggestions?

Thanks all!

In case anyone ever needs it, I found the log file for the SYSTEM user. The path is as follows, assuming Windows 11

C:\Windows\System32\config\systemprofile\AppData\Local\rclone

So that's part I answered! I was able to clean the cache and regain the space. My issue is, why didn't RClone obey the parameters and begin the upload? Did I do something wrong? Otherwise, running as a service worked surprisingly well.

Without seeing a log file, it's tough to guess what the issue was.

You ran the logfile with "-vv" so that's going to generate quite the log file depending on what you are doing.

Upload the log file and share a GDrive link.

There's noting to show what it did as there's no log file.

It can exceed the max size, but that is a bit more specific and documented here:

rclone mount

I got rid of that 18 GB behemoth and ran the service as follows (taking away the -vv flag). All seems to be well now. My Acronis back up ran yesterday without issue and the disk space is where it should be. The kicker seemed to be the delay restart parameter in NSSM. It needed to be set to 10000 ms in throttling. The rest, I left alone. The command that worked was this one:

mount gdrive-media-crypt: X: --allow-other --dir-cache-time 2h --poll-interval 10s --vfs-cache-mode full --vfs-cache-max-size 50G --vfs-cache-max-age 2h --vfs-read-ahead 2G --no-console --config C:\RClone\config\rclone.conf --log-file C:\RClone\logs\log.txt

For whatever reason, both you and @ncw have walked me through both my Windows and Mac server issues this week. Everything is working as it should. A lot of this stuff is reaching out for help, and trial and error yourself. Hopefully, this post helps someone else if they hit the same snag.