Rclone and Kopia

What is the problem you are having with rclone?

(I'm very new at Rclone, so bear with me here)
To set up a Rclonre remote repository on KopiaUI, I need the Rclone Remote Path.
I'm trying to backup everything in my computer into the "backup" folder in remote 2 (uscgdrive)
My understanding is that the Rclone Remote Path would be "uscgdrive:backup".
However, Kopia tells me "Connect Error: INTERNAL: internal server error: unable to start rclone: exec: "rclone": executable file not found in $PATH"

I thought it was a school account permission whatever thing, but I tried it with a personal account (gmaildrive:backup), and it does not work either.

I noticed this line here"define as many storage paths as you like in the config file" in Documentation
I don't remember defining storage paths, or I have and I just don't know?

Anyways, please tell me how to find Rclone Remoth Path and make Kopia and Rclone talk to each other
Much thanks!

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.0

  • os/version: darwin 13.4.1 (64 bit)
  • os/kernel: 22.5.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.20.5
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

remote1(gmaildrive): Personal Google Drive
remote2(uscgdrive): School Google Drive

The rclone config contents with secrets removed.

type = drive
scope = drive
token =
team_drive =

type = drive
scope = drive
token =
team_drive =

It is not really rclone issue but rather kopia configuration..

Kopia can not find rclone.exe.

In kopia you you have to provide two things:

Rclone remote path: uscgdrive:backup
Rclone executable path: C:\path\to\rclone.exe

Remote path if does not exist will be created automatically.

I found the path: /Users/syr/.config/rclone/rclone-v1.63.0-osx-amd64

But now Kopia said "Connect Error: INTERNAL: internal server error: unable to start rclone: fork/exec /Users/syr/Documents/rclone-v1.63.0-osx-amd64: permission denied"

I'm on mac Ventura btw

How do I grant access? Is there a command or something? I dug around in settings and couldn't find something like grand Kopia access to folder. I could grant Kopia full disk access, but I don't exactly want to do that if there are other safer choices.

how did you install rclone?

I ran this in the terminal

Yvonne-vMac:~ syr$ sudo -v ; curl https://rclone.org/install.sh | sudo bash
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 4707 100 4707 0 0 8159 0 --:--:-- --:--:-- --:--:-- 8301
Archive: rclone-current-osx-amd64.zip
creating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/
inflating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/git-log.txt [text]
inflating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/rclone [binary]
inflating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/rclone.1 [text]
inflating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/README.html [text]
inflating: tmp_unzip_dir_for_rclone/rclone-v1.63.0-osx-amd64/README.txt [text]

rclone v1.63.0 has successfully installed.
Now run "rclone config" for setup. Check Documentation for more details.



which rclone

I get:

Yvonne-vMac:~ syr$ which rclone

1 Like

this is the path you have to enter in kopia as Rclone executable path

YAY it worked Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.