Rclone 1.61 issue with mount google drive

What is the problem you are having with rclone?

error with upload and use rclone mount with google drive

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: rocky 9.1 (64 bit)
  • os/kernel: 5.14.0-162.12.1.el9_1.0.2.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount \
        --allow-other \
        --cache-tmp-upload-path=/tmp/rclone/upload \
        --cache-chunk-path=/tmp/rclone/chunks \
        --cache-workers=8 \
        --cache-writes \
        --cache-dir=/tmp/rclone/vfs \
        --cache-db-path=/tmp/rclone/db \
        --no-modtime \
        --drive-use-trash \
        --stats=0 \
        --checkers=16 \
        --vfs-cache-mode=minimal \
        --dir-cache-time=60m \
        --cache-info-age=60m remote-gdrive:/bck /mnt/gdrive 

The rclone config contents with secrets removed.

type = drive
client_id = my_client
client_secret = my_secret
scope = drive
acknowledge_abuse = true
token = {"access_token":"...................
team_drive = 123456789
root_folder_id =
stop_on_upload_limit = true
stop_on_download_limit = true

A log from the command with the -vv flag

ERROR: ,,, Failed to copy: googleapi: got HTTP response code 429 with body:
<html><head><meta http-equiv="content-type" content="text/html; charset=utf-8"/><title>Sorry...</title><style> body { font-family: verdana, arial, sans-serif; background-color: #fff; color: #000; }</style></head><body><div><table><tr><td><b><font face=sans-serif size=10><font color=#4285f4>G</font><font color=#ea4335>o</font><font color=#fbbc05>o</font><font color=#4285f4>g</font><font color=#34a853>l</font><font color=#ea4335>e</font></font></b></td><td style="text-align: left; vertical-align: bottom; padding-bottom: 15px; width: 50%"><div style="border-bottom: 1px solid #dfdfdf;">Sorry...</div></td></tr></table></div><div style="margin-left: 4em;"><h1>We're sorry...</h1><p>... but your computer or network may be sending automated queries. To protect our users, we can't process your request right now.</p></div><div style="margin-left: 4em;">See <a href="https://support.google.com/websearch/answer/86640">Google Help</a> for more information.<br/><br/></div><div style="text-align: center; border-top: 1px solid #dfdfdf;"><a href="https://www.google.com">Google Home</a></div></body></html>

i use rclone to mount a remote on my server and backup my files over rclone.
it worked fine for many years, but now i have this issue on few servers...

thank you

if i check with
ls /mnt/gdrive
works fine
also if i run
mkdir /mnt/gdrive/test123

thank you

Hit search.

Type in 429 issues.

Read through the threads see if those apply.

sorry, i seached and found solution...

i changed my mount servcie with
--drive-upload-cutoff 1000T
--bwlimit 12M
--tpslimit 5

before i used

now seems works fine.
but now when i write a file on google drive, rclone save it on cache and "after" upload on google drive.
of course it's how caching works...

but if i wanted to know when cache is clean, in other word when my file is "ok" on google drive, how i can do?

my goal is to be sure my backups are on google drive

thank you again