Rclone 1.55.1 release

Rclone 1.55.1 has been released. Find it here https://rclone.org/downloads/ or use rclone selfupdate to upgrade.

This is a bugfix release containing a lot of little fixes, the most important ones being the fixes to the SFTP and Dropbox backends.

Note that because of a bug in rclone selfupdate fixed in this release, if you run rclone selfupdate it might not work this time on non Windows/macOS platforms. Do give it a try though!

v1.55.1 - 2021-04-26

See commits

  • Bug Fixes
    • selfupdate
      • Dont detect FUSE if build is static (Ivan Andreev)
      • Add build tag noselfupdate (Ivan Andreev)
    • sync: Fix incorrect error reported by graceful cutoff (Nick Craig-Wood)
    • install.sh: fix macOS arm64 download (Nick Craig-Wood)
    • build: Fix version numbers in android branch builds (Nick Craig-Wood)
    • docs
      • Contributing.md: update setup instructions for go1.16 (Nick Gaya)
      • WinFsp 2021 is out of beta (albertony)
      • Minor cleanup of space around code section (albertony)
      • Fixed some typos (albertony)
  • VFS
    • Fix a code path which allows dirty data to be removed causing data loss (Nick Craig-Wood)
  • Compress
    • Fix compressed name regexp (buengese)
  • Drive
    • Fix backend copyid of google doc to directory (Nick Craig-Wood)
    • Don't open browser when service account... (Ansh Mittal)
  • Dropbox
    • Add missing team_data.member scope for use with --impersonate (Nick Craig-Wood)
    • Fix About after scopes changes - rclone config reconnect needed (Nick Craig-Wood)
    • Fix Unable to decrypt returned paths from changeNotify (Nick Craig-Wood)
  • FTP
    • Fix implicit TLS (Ivan Andreev)
  • Onedrive
    • Work around for random "Unable to initialize RPS" errors (OleFrost)
  • SFTP
    • Revert sftp library to v1.12.0 from v1.13.0 to fix performance regression (Nick Craig-Wood)
    • Fix Update ReadFrom failed: failed to send packet: EOF errors (Nick Craig-Wood)
  • Zoho
    • Fix error when region isn't set (buengese)
    • Do not ask for mountpoint twice when using headless setup (buengese)

thanks much for the ever improving documentation.

tho i am not seeing a change at https://rclone.org/commands/rclone_mount/#installing-on-windows
"To run rclone mount on Windows, you will need to download and install WinFsp" points to
http://www.secfs.net/winfsp/ which if you click the download button, which will download the old version

perhaps the docs should point to https://github.com/billziss-gh/winfsp/releases/tag/v1.9

I've asked Bill about that...

I'd rather not point to a specific version, but we could point to https://github.com/billziss-gh/winfsp/releases?

agreed. that is the correct link. thanks

Love selfupdate! Worked flawless for me on windows.

1 Like

Running sudo rclone selfupdate on my M1 Macbook Pro I get:

2021/05/09 13:03:23 Error: failed to update rclone: failed with 404 Not Found downloading https://downloads.rclone.org/v1.55.1/rclone-v1.55.1-darwin-arm64.zip

Can you download v1.55.1 manually then try selfupdate again? Maybe update to the beta with the --beta flag then back to --stable? I think we fixed this bug already but I can't remember!

I updated manually to 1.55.1 and then tried:

rclone selfupdate --beta

But still got this:

2021/05/10 07:50:13 Error: failed to update rclone: failed with 404 Not Found downloading https://beta.rclone.org/v1.56.0-beta.5482.732bc08ce/rclone-v1.56.0-beta.5482.732bc08ce-darwin-arm64.zip

We fixed something similar in install.sh, not in selfupdate.

install.sh replaces darwin by osx in URL

selfupdate, at least in 1.55.1, also tries to do that

But user logs show darwin in the URL :wink:

I replace GOARCH instead of GOOS, here's the bug. :frowning_face:

Well spotted! And thank you @webreaper for reporting.

1 Like

I hope I fixed this bug. The patch has been released today as latest rclone beta. If you wish, you can try it now. Install forked copy of latest beta from Release v1.55.0-selfupdate-osx · ivandeex/rclone · GitHub to a test location and run /test/path/rclone selfupdate --beta. It should run to completion. I can't build arm64 but amd64 should work fine thanks to Rosetta, so please install it to a temporary location for this test, don't overwrite arm64 rclone binary. If you confirm, it will be included in the 1.56 release.

1 Like

Looks good:

user@Marks-MacBook-Pro rclone-v1.55.0-selfupdate-osx-osx-amd64 % ./rclone version
rclone v1.55.0-selfupdate-osx
- os/version: darwin 11.4 (64 bit)
- os/kernel: 20.5.0 (x86_64)
- os/type: darwin
- os/arch: amd64
- go/version: go1.16.4
- go/linking: dynamic
- go/tags: cmount
user@Marks-MacBook-Pro rclone-v1.55.0-selfupdate-osx-osx-amd64 % ./rclone selfupdate --beta
Successfully updated rclone from version v1.55.0-selfupdate-osx to version v1.56.0-beta.5486.119bddc10
user@Marks-MacBook-Pro rclone-v1.55.0-selfupdate-osx-osx-amd64 % ./rclone version
rclone v1.56.0-beta.5486.119bddc10
- os/version: darwin 11.4 (64 bit)
- os/kernel: 20.5.0 (x86_64)
- os/type: darwin
- os/arch: amd64
- go/version: go1.16.4
- go/linking: dynamic
- go/tags: cmount

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.