Quota Exceeded with Google Photos

I'm running Linux Mint 20.1, attempting to mirror my Google Photos locally.

rclone v1.50.2
 - os/arch: linux/amd64
 - go version: go1.13.6

When I run rclone sync photos:media/by-month/ $HOME/gphotos/media/by-month/ -P I get the following 429 error part way through the run. The run continues with this error coming up over and over again.

I added some newlines for clarity

2021-07-12 08:50:20 ERROR : 2013/2013-04: error reading source directory: couldn't list files:
Quota exceeded for quota metric 'Read requests' and limit 'Read requests per minute per user'
of service 'photoslibrary-dot-googleapis-dot-com' for consumer 'project_number:nnnnnnnnnnnnn'.

It appears that rclone just goes to the next directory and attempts to sync, getting another 429 error. I would expect that either rclone would stop after a 429, or it would throttle back.

I worked around the issue by running the following script...


for y in $(rclone lsf --dirs-only photos:media/by-month/)
    echo "Got ${y}"
    for m in $(rclone lsf --dirs-only photos:media/by-month/${y})
	echo "Got ${y}${m}"
	/usr/bin/rclone sync photos:media/by-month/${y}${m} $HOME/gphotos/media/by-month/${y}${m}

hello and welcome to the forum,

before stating that rclone has a bug, please update rclone and test again.
the version you are using is approx 18 months old.....

if you search the forum, it is common to exceed quota with google photos, as the value to hit a quota is much lower then google drive.
one workaround is to use --tpslimit 1

did you create your own client id as that helps.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.