Question on valid rclone options for bisync

What is the problem you are having with rclone?

Hi,

I'm a new rclone happy and grateful user, for I missed a pCloud client app for Linux on ARM aarch64, and a friend pointed me to rclone, which is so great.

However when I tried to “bisync” with pCloud I noticed it takes hours unless I use the --ignore-checksum flag - then it only takes a few seconds.

However I first tried --ignore-listing-checksum as mentioned on the website doc at rclone bisync but my rclone doesn't recognize it as a valid option, so I wonder whether the documentation, or my rclone version, could be outdated ?

Same I had issues with copying symlinks, and rclone output itself advised me to try --copy-links, still the option is not recognized and I ended up with using --links, that seems to work.

However it is unclear to me if --ignore-listing-checksum and --copy-links are supposed to be supported, and what the difference would be between --links and --copy-links : Would one copy the symlink as a symlink, and the other dereference it and copy the file contents instead ?

Also, I have mounted an rclone mountpoint to pCloud, on which I experience read errors on a Raspberry Pi 4 when trying to syncing in Joplin, but the same works good on a Pinebook Pro with the exact same setup, so I wonder...

TIA for any clarification.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1

  • os/version: arch 23.02 (64 bit)
  • os/kernel: 6.1.52-1-MANJARO-ARM-RPI (aarch64)
  • os/type: linux
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.20.6
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

pCloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone bisync

(That's a valid options question, please see above)

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

Doesn't work here, although I have the lastest version available in the Arch / Manjaro repositories, which I then assume not to be the latest ?

Update your rclone to the latest version - v1.64

There was a lot of improvements and fixes in bisync done recently.

1 Like

Thanks,
I'd rather use my distro repos than manual software installs, otherwise a workstation soon becomes a mess that is quite hard to maintain in the long run...
But using Arch/Manjaro the repos are usually very up-to-date, so I guess that the latest version will make it to there soon.

Meanwhile I still would be intereted in the difference between --links and --copy-links...

These two options only apply to local filesystem:

copy-links - Follow symlinks and copy the pointed to item.
links - Translate symlinks to/from regular files with a '.rclonelink' extension.

Use --links if you want to preserve links and --copy-links when you want to copy content links point to

More details in docs.

You have not provided any details or logs so impossible to guess what can be wrong. I would suggest you open new topic and answer all questions from the template.

This is the answer. :slight_smile: --ignore-listing-checksum is a new flag added in v1.64, so it will not work in older versions.

My best guess (without seeing a log) is that you may be running into this known issue regarding overridden configs. This is because --copy-links is a backend-specific flag for the local remote.

1 Like

Yes, I feel I've better wait for v1.64 to hit the Manjaro repos before I investigate this more in depth, given the amount of changes...

1 Like

I'm glad to report that upgrading to v 1.64 seems to have fixed most of bisync erratic behaviour here :grin:

1 Like

We love to hear it! :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.