Question max-age

What is the problem you are having with rclone?

I cant copy files from one date

What is your rclone version (output from rclone version)

Last version rclone

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 and linux

Which cloud storage system are you using? (eg Google Drive)

google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copyto -v --dry-run --max-age 2020-07-20 src001:/ dst001:/ 

Show this error:

Fatal error: invalid argument "2006-01-02" for "--max-age" flag: strconv.ParseFloat: parsing "2006-01-02": invalid syntax


What version are you running?
Can you share a debug log?

felix@gemini:~$ rclone ls GD: --max-depth 1 --max-age 2020-07-20 -vv
2020/07/21 07:37:13 DEBUG : --max-age 1.4841879378639466d to 2020-07-19 20:00:00.000011265 -0400 EDT m=-128233.812820161
2020/07/21 07:37:13 DEBUG : rclone: Version "v1.52.2-214-g67098511-beta" starting with parameters ["rclone" "ls" "GD:" "--max-depth" "1" "--max-age" "2020-07-20" "-vv"]
2020/07/21 07:37:13 DEBUG : Using config file from "/opt/rclone/rclone.conf"
2020/07/21 07:37:14 DEBUG : hosts: Excluded
2020/07/21 07:37:14 DEBUG : jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv: Excluded
2020/07/21 07:37:14 DEBUG : hosts.txt: Excluded
2020/07/21 07:37:14 DEBUG : 4 go routines active

Hello, solved, was version problem

On version 1.52.3 works fine on older version I attach the problem, perhaps helps somebody if search for the same error .....

Rclone version on windows:
rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

rclone ls -vv team1:/ --max-age 2020-07-15 --config "rclone.conf"


Error: invalid argument "2020-07-15" for "--max-age" flag: strconv.ParseFloat: parsing "2020-07-15": invalid syntax
rclone ls remote:path [flags]

-h, --help help for ls

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.

2020/08/19 16:21:53 Fatal error: invalid argument "2020-07-15" for "--max-age" flag: strconv.ParseFloat: parsing "2020-07-15": invalid syntax.

Other Question

Can I filter with date and time? example:

rclone ls -vv team1:/ --max-age 2020-08-19 15:00:00 --config "rclone.conf"

And what zone time use rclone, If I put 2020-08-19, copy all after 00:00 UTC ????.


Check out:

Hello again, with new version it works fine but gdrive has a singular option,
A filE has:

Whan I copya file this file may be so:
LAST TIME MODIFIED 2020-05-20 --> I think this date is the first time this file uploaded.
CREATED (by me on my gdrive) 2020-09-12 is the time I copy this file from other gdrive.

There are option to copy taking the date of creation?.

If i use:
rclone copy to src:/ dst:/ --max-age "2020-09-11" dosnt copy anything
rclone copy to src:/ dst:/ --max-age "2020-05-20" copy this file, rclone takes the original date.

I want use the other date, the date uploaded by me.
Attach picture.



Other thing I dosnt understand, why I use
rclone copy to src:/ dst:/
And the files on destination have the date of modificated?, if I am copying it downloading and uploading....
rclone takes the date of this file?? or gdrive??.


You can try this flag

Rclone tries to preserve the modification date.

1 Like

Hello, lot of thanks, as on the Forrest Gump Film say....
You're a damn genius

Has thought of everything???!!!!!!!!!!!!!


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.