Question about rclone lsf in Windows10

rclone lsf in Windows is producing output separated by LF, so redirection to files ( such as >output.txt) produces difficult to read text.
Is there any way to configure a flag to use as separators CR & LF?

In the mean time, unix2dos seams a good solulion


Not currently…

I thought windows dealt with LF separated text files now-a-days? I suppose it depends on which editor you are using.

Theoretically NotePad in W10 does… not tried.

It would be easy enough to add a flag for this if it turns out to be important to you.

I can survive without it, now that I managed to find a workaround.
It would be nice to have it because I could pipe output of rclone to another rclone command. But I can use an intermediate temp file.

I am struggling to reorder and rename files and folders.

I used to use Rclone Browser for renaming, but I found a bug (if rename file.mp4 to file.mp4.txt what it makes is to create a folder called file.mp4.txt and moves file.mp4 to that folder (seems it uses move and not moveto…) ; besides the developer has mostly abandoned it and it is hardly compatible with last versions of rclone.
Also rclone mount is having its issues in W10.

So, lacking a GUI I need to fall back to CMD, and it is really a pain in the back… List folders and files, create list of source and target paths and name, and do move and moveto …
Probably would be faster to download all, reorder locally and reupload again…

So, the flag is really the last of my worries…
Thanks again!

What about using an rclone mount?

Scratch that, you are trying that in the other thread :wink: