Pulling from driopbox error -- comitting uploads -- please wait

What is the problem you are having with rclone?

on pulling from dropbox -- it hangs with "committing upload -- please wait"

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1

  • os/version: debian bookworm/sid (64 bit)
  • os/kernel: 6.6.6-76060606-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Dropbox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone copy --update  --verbose --transfers 30 --checkers 8 --contimeout 60s --timeout 300s --retries 3 --low-level-retries 10 --stats 1s dropbox:onyx/Tabx/Notepads/civ ~/org-roam/files/goldin/civilization

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[dropbox]
type = dropbox
token = XXX

[google-drive]
type = drive
scope = drive
token = XXX
team_drive =

Paste config here

A log from the command that you were trying to run with the -vv flag

not sure where to find the log. I am a non-programmer type

welcome to the forum,

you are using --verbose so there should be output in the terminal

for testing, might start with a simpler command,
/usr/bin/rclone copy --update --verbose dropbox:onyx/Tabx/Notepads/civ ~/org-roam/files/goldin/civilization

and it might not be clear from the rclone docs, but should do the following
https://rclone.org/dropbox/#get-your-own-dropbox-app-id

This is most likely far too many for dropbox. Remove these flags and use default values here.

In addition add --tpslimit 12 --tpslimit-burst 0 to your command to try to stay within dropbox acceptable transactions rate.

as per rclone docs, i believe that should be ok, if the OP creates a client id/secret
Using this mode means you can use a much higher --transfers parameter (32 or 64 works fine)

but @Animosity022 might know best?

That worked. I still get the message: "committing uploads..." But now at least the files get transferred.Thanks so much. I am a non-programmer who uses emacs and org-roam for academic papers, so I very much appreciate the help and your forbearance.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.