Proxy for Amazon Cloud Drive


#105

I just uploaded a 250mb file without issues to Amazon Germany.

In which country are you using Amazon Drive?

€dit: I used rclone 1.38 in combination with Rclone Browser on Win10


#106

US/Macintosh
rclone v1.38-030-g94171947β

  • os/arch: darwin/amd64
  • go version: go1.9

Like I said…it did work for about 250GB…but then it pretty much stopped.


#107

Thanks for your job. I was using oDrive but it’s very slowly.

Works fine with the 1.38 stable version of rclone.


#108

It did awaken for about 2TB, but then it stopped again. Not a big deal as ACD unlimited is going the way of the dodo…but just curious is all.

TIA


#109

I don’t know what happened to ACD in the last couple of days but I was trying to upload some things today and the upload speeds became pretty bad. It averaged at 550 kbytes/s, what is even worse than my upload speed at home.

My setup: Scaleway VC1S VPS
File size: 100mb and 140mb
Rclone 1.38 & latest Beta

€dit: The latest Beta seems to almost double the upload speed to ACD.

@ncw, afaik you also use ACD with rclone, do have any idea what the reason could be for this issue? Are you experiencing this yourself?


#110

I haven’t seen the issue, but I do find ACD to be the most variable in performance of the cloud providers.


#111

For what it is good:

To me, it seems to be specifically an upload (speed) issue to ACD.
Downloading does work at good speeds.

Downloading round about 200mb to the server is a matter of seconds, while uploading almost takes 4 minutes.


#112

Hi all, not sure if this is only happened to my account only or if everyone else is having this experience as it was working perfectly previously. Since last night I kept having Rate limited issues, I did rclone copy using the parameters “–transfers=1 --checkers=1 --tpslimit=1 --acd-templink-threshold=0 --fast-list” and I got the following:

2017/10/27 07:58:11 DEBUG : pacer: Rate limited, sleeping for 177.671812ms (1 consecutive low level retries)
2017/10/27 07:58:11 DEBUG : pacer: low level retry 1/10 (error )
2017/10/27 07:58:12 DEBUG : pacer: Rate limited, sleeping for 264.058441ms (2 consecutive low level retries)
2017/10/27 07:58:12 DEBUG : pacer: low level retry 2/10 (error )
2017/10/27 07:58:13 DEBUG : pacer: Rate limited, sleeping for 225.101885ms (3 consecutive low level retries)
2017/10/27 07:58:13 DEBUG : pacer: low level retry 3/10 (error )
2017/10/27 07:58:14 DEBUG : pacer: Rate limited, sleeping for 4.901498295s (4 consecutive low level retries)
2017/10/27 07:58:14 DEBUG : pacer: low level retry 4/10 (error )
2017/10/27 07:58:15 DEBUG : pacer: Rate limited, sleeping for 4.451715081s (5 consecutive low level retries)
2017/10/27 07:58:15 DEBUG : pacer: low level retry 5/10 (error )

By the way I’m using Version “v1.37-DEV” as I’m moving from ACD to Opendrive but wasn’t having issues for the past 2-3 weeks. Thanks.


#113

I tried it again and today it had decent speeds with exactly the same setup I posted a few posts above.
Really weird!


#114

Hi guyes.
I try the proxy today but failed.
I used rclone 1.38 and existing config. I run the procedure on top a few times but get back an error:


Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> y
    If your browser doesn’t open automatically go to the following link: http://127.0.0.1:53682/auth
    Log in and authorize rclone for access
    Waiting for code…
    Got code
    2017/11/11 15:01:52 Failed to configure token: failed to get token: oauth2: cannot fetch token: 401 Unauthorized
    Response: {“error_description”:“Client authentication failed”,“error”:“invalid_c
    lient”}

any clues what i´ve done wrong?


#115

I had an issue using rclone v1.38-095-g413faa99β.
After having followed your procedure and having put my Amazon’s userid and password, I’ve been redirected to a browser page with the message “Authorization failed”.
It’s strange, as I used the working credentials I already use for Amazon. Can it depend by two-factor authentication I’ve enabled?


#116

It seems to be having some issues today. I was doing a transfer and just got spammed with

"error" : "disabled_client",

"error_description" : "The OAuth client was disabled."


#117

Hi, I have a doubt. What “privacy notice URL” do I set in login with amazon?. I set amazon cloud drive url, but didn’t work. I always see “fetch error” when I try config rclone with proxy oauth.


#118

hello,
i had to reinstall windows 10 so i lost all rclone/rclone browser configuration even if those are stored and used from a different partition (not on the OS partition)
so i started the procedure from this thread (as i did it before for a couple of times and it worked) but today it did not work.

i get to the part where the browser opens for me to insert my amazon credentials - i do that - and i get to a page (on AMAZON.COM) that tells me i have to enable cookies.

so i cannot get a code and the config halts at “waiting code”.

so i cannot configure rclone browser.

can anyone confirm?
can anyone help?

LATER EDIT:
on the page that requires me to enable cookies there’s a go to previous page button.
i click on that.
i get redirected to a proper amazon.com page
i log in… it sends me a code to verify my identity…
i manage to log into AMAZON.com and the config procedure finishes with succes…


#119

I’m trying to configure my German ACD account as a new remote following the steps in the OP. But at the stage where I have to log into amazon (via the proxy), it looks like it is asking me to log into amazon.com rather than amazon.de (and hence it doesn’t work. How can I log into amazon.de?


#120

Amazon decide where to send you for authorization - it should work even if they send you to .com. I’m based in .co.uk and it works for me.


#121

I’m going to close this topic now as it has got very long - please open a new topic if you need to discuss further - thanks!


#122