Proxy for Amazon Cloud Drive


#84

Thanks so much! I will try it.


#85

the auth on my remote machine with the headless auth don´t work… having an error message from the amazon homepage:
Error Summary
400 Bad Request
Unknown client_id
Request Details
access_type=offline
client_id=rclone
redirect_uri=http%3A%2F%2F127.0.0.1%3A53682%2F
response_type=code
scope=clouddrive%3Aread_all+clouddrive%3Awrite
state=41b6ce787890290af7d22e9995317a4b


#86

Worked flawlessly for copying data back and forth between gdrive and acd again, thanks a lot @ncw!


#87

i use this method. after a while, amazon banned my account. i would suggest not to.


#88

I have the same problem. I cannot authorize my account.

Any help here?

I am using the follow version:
rclone v1.37-101-g0158ab69β

  • os/arch: linux/amd64
  • go version: go1.8.3

Thanks
Alessandro


#89

Correction.
I followed the procedure outlined at the beginning of this post and it worked perfectly.

Thanks
Alessandro


#90

I tried to install it locally on my mac to copy the config file after this to an server to copy from an US ACD to an German ACD. When I come to the point with the login I got an 403 response. Is this because of the ban of rclone?


#91

If you follow the procedure at the top it should work. Make sure you have a new version of rclone at both sides.


#92

I used the latest version and got already the 403 response on my local machine while the config.


#93

I tried now several times and always got the 403. Now when I try it, the webpage for the authorization says “Authorization failed”


#94

Can you get it working locally on your mac?


#95

Until now I only tried it on the make. I wanted to copy the config afterwards to the server.


#96

last time i use this i get banned from acd. the first time after 3 days non stop, i get banned. i had to contact support to release me from ban for me to be able to log in to my account. after multiple time being banned and unbanned, the time it took to ban been reduce to 1 day from 3 days. after multiple time being banned, i decided to use odrive. no bans so far.

anyway, i assume, acd still banned rclone and using workaround triggers something suspicious on amazon hence the ban. by the way, im from malaysia(if that means something)


#97

Are the authorization credentials save on the local machine? It seems like the login data is wrong. But I didn’t finished the config.


#98

The proxy still works, not that I wanted to really use it but here is what happened!

Some months ago I asked amazon to stop my billing and they said fine, refund, your account will be over quota and files will be removed after 180 days or something if you don’t remove them. I think I removed what I had (or maybe not) anyway I go yesterday and not only I’m still over quota but a lot of the files and folders I had (well organized, I’ve had only a few folders under amazon’s root) are now moved randomly to root!

Ok, I said, time to clean up. I go with rclone and remove all folders except documents, pictures (the default folders) and “My Send-to-Kindle Docs” (this is the only folder that has something, some books which I’ve sent to kindle). I verify in their web interface, everything seems good - only these files. I try to empty the trash but it goes only some thousands of files at a time, I give up.

Now after a few hours again I’ve got some (a lot) of (my!) files back in amazon’s root! Anybody had something similar?


Newby ACD Haters and Issues Question
#99

Is anyone still using this?

I use acd as a secondary backup as they still offer ‘unlimited’ for EU accounts, but recently it often seems to be throwing the 429 errors when trying to get files out or mounting the drive.

It seems to work fine when uploading files.

Don’t know if it’s just Amazon having issues or something more serious.


#100

I have been testing this for the last two weeks (give or take) and it has been working flawlessly.


#102

Irrelevant answer as the previous question was withdrawn

The instructions are in the first post


#103

I had it working for a bit last night, but now the speed has dropped to zero, I can see that it is attempting to transfer the files(It has filenames). I transferred quite a bit last night, but it stopped after an hour or so.

I tried recreating the remote, with the same settings as before, also tried getting a new token. Is there something else I am missing? Does the connection I have run through your proxy? Killing your connection?

On gigabit and trying to rescue my data from ACD


#104

I have the same problem, at first I thought it was a problem with the files like> 8 GB. And now I do not want to copy even .txt files :confused: