Proxy for Amazon Cloud Drive


#44

Working amazingly thus far. Thanks!


#45

Yeah I saw the bug report, but I had the same issue with the latest beta unless the -latest package in the file listing wasn’t the latest. I had the same issue on osx and linux. It’s working now without issue so I have no idea what happened. I tried to log the error and it just didn’t occur.


#46

I’m doing the config for each system individually. Latest Beta. I just wiped my config file and am trying again. And I’m only doing one instance at a time now. Before I had other CMD’s doing other operations.

Edit: It’s been quite a while and it works now. Remaking a fresh config took a while but has been working great. I’m transferring from ACD to my GSuite at a mindblowing 4.5Gbps.


#47
Response: {"error_description":"Client authentication failed","error":"invalid_client"}

I used to get the above error too when I edited my existing remote with the main post steps.
Fixed it by deleting the existing remote config and then creating a new one with above steps.


#48

It appears proxy no more work :+(


#49

Seems there’s an issue when copying config: If two clients refresh the config one after the other, the latter one will be invalidated. For server users, I suggest forget about the remote config stuff and use w3m instead.


#50

Does this work anymore? Because I cant make it work. It seems Amazon has disabled it.


#51

Works fine here - As ncw suggested, might be the config. Check your version.

One has been running for 198h without problems and another machine has been running for 48h without problems. Got two machines syncing from Gdrive to Amazon at the same time.


#52

This is “somewhat” working for me … but extremely slow speeds; <100 kbps on a 1gbps connection.

-vv shows:

DEBUG : pacer: low level retry 2/10 (error HTTP code 400: "400 Bad Request": response body: "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<Error><Code>InvalidArgument</Code><Message>Only one auth mechanism allowed; only the X-Amz-Algorithm query parameter, Signature query string parameter or the Authorization header should be specified</Message><ArgumentName>Authorization</ArgumentName><ArgumentValue>Bearer Atza|...</ArgumentValue><RequestId>...</RequestId><HostId>...</HostId></Error>")

Any way to speed this up?


#53

Works like a charm!
I’ve set up acd on my headless Raspberry Pi. Instead of using the remote setup as described here https://rclone.org/remote_setup/ I just ran the normal setup (see ncw’s first post) on my windows machine until I got the token. It’s shown in the cmd and can easily be copied from there.

Thank’s a lot to @ncw and the anonymous donor of the credentials! You are awesome!

The only drawback remaining: acd is getting unattractive anyway, because of changing the conditions: https://www.amazon.com/b?node=16591160011


#54

I’ve been having the same issue as @ZeroG. Has anyone else figured out what the issue is or how to work around it? The proxy was working flawlessly prior to these errors and the config hadn’t changed (though I’ve tried recreating the acd remote to no avail). Still having the same issue on the newest beta as of 6/26 too.


#55

@transcendenz, @ZeroG

Try adding --acd-templink-threshold 0 to your rclone command. It seems like ACD has changed the file size threshold for downloading via a tempLink. By setting it to 0, a tempLink is always used. Worked for me at least.


#56

That seems to work for me too, thanks @fgump!


#57

Thanks a lot for this work .

To ACD Team : i don’t abuse your service, just I use this like a backup and I pay for this. If you block again rclone, I’ll ask a refund and go to Hubic or to Google Drive or any others solution.

Edit : Even if I use the latest beta, the token is valid until one hour, is it “normal” ?


#58

The token validity is set by the service providing the token; in this case it’s Amazon who sets the one hour time limit. Applications such as rclone have to refresh the token when it expires. The proxy is used to talk to Amazon to get the new token.


#59

Yes but how should i load rclone to refresh token each 59 min ?..


#60

Most likely you aren’t using the latest beta - you need to use it for initial authorisation and for doing the transfers.


#61

Thanks for your answer. On my windows i used the last beta but not on my linux server…
I find the mistake :slight_smile: …I don’t copy the new beta in the good directory :smiley:

nicolas@ServUBU-VM:~/rclone-v1.36-231-g575e779bβ-linux-amd64$ rclone -V
rclone v1.35
nicolas@ServUBU-VM:~/rclone-v1.36-231-g575e779bβ-linux-amd64$ /usr/bin/rclone -V
rclone v1.36-231-g575e779bβ
nicolas@ServUBU-VM:~/rclone-v1.36-231-g575e779bβ-linux-amd64$ /usr/s
sbin/ share/ src/
nicolas@ServUBU-VM:~/rclone-v1.36-231-g575e779bβ-linux-amd64$ /usr/sbin/rclone -V
rclone v1.35

So i’ll retry now :slight_smile:


#62

Any idea why I cannot create the configuration file? I am getting "
We’re sorry!
An error occurred when we tried to process your request. Rest assured, we’re already working on the problem and expect to resolve it shortly."

I am using the latest rclone beta
[4ftermath@fileserver ~]$ rclone -V
rclone v1.36-250-gb5002eb6β


#63

double check that you got these configs right is all I can think of

client_id> rclone
client_secret> acd
auth_url> https://quixotic-module-170120.appspot.com/auth
token_url> https://quixotic-module-170120.appspot.com/token