Proxy for Amazon Cloud Drive


#23

That looks like there is a problem refreshing the token. Refreshing the token works fine when I try it manually (also on an amazon UK account).

When you say “works for about an hour” are you using rclone continuousy in that period, or are you using it intermittently?

Is the config file you are using on the Windows machine in use on the windows machine at the same time?


#24

To answer your questions first:

  1. Agree it’s the refresh that’s the problem.
  2. Yes, using it continously on the linux machine
  3. No, not in use on the windows machine.

However! I might have found the problem - Going on 1h13m now - When I was uploading the new file config file via FTP, it seems it only got the file permissions for user to read/write (600) - Note, the user running rclone and the user uploading via FTP are the same, so it should not give any permissions errors, but seems there is something going on.

I changed the permissions on the rclone config file to just allow everyone(777) and it seems to have worked on the first refresh.

I just checked the config now and it has been reset to filepermission (600) after the token refresh. I’ll try to see if it can still refresh next time.


#25

rclone resets the permissions to 600. However it needs to write to the file so if the file isn’t owned by the user running rclone then there will be trouble… There is an issue here which may be relevant: https://github.com/ncw/rclone/issues/1467


#26

It is owned by the same user.

Just got the error again - Is there some extra log or something I can do? Perhaps I should go make a issue instead?


#27

What I could really do with is a log with --vv --dump-bodies of the problem happening. However that isn’t going to work well while doing lots of uploads! If you could do one with -vv --dump-headers that would be useful - I’d like to see the transaction that caused the 401.

I can try to make a synthetic test uploading some files really slowly to see if I can replicate the problem.

If you quit rclone after it has that error and restart it, does it start working again?

Making an issue is a good idea - it won’t get lost then!


#28

Can confirm that it is working for now. Currently pulling all my data from ACD. Thank you @ncw and to the very kind rClone user who provided this proxy.


#29

Made a issue here https://github.com/ncw/rclone/issues/1475

Added log as well - Quitting and restarting makes no difference


Is Amazon working again?
#30

Thanks for this … is it currently working?

Doesn’t this give you access to my data?


#31

Yes I think so

No, the proxy doesn’t store any tokens which pass through it.


#32

Amazing ! That is working great and is really promising for the future.
I tried other programs suggested by Amazon that are so badly documented, ncw @rclone your far the best.
Thank you thousand times.


#34

If enough people abuse the system (i.e storing >10TB), they will do for sure, as did Amazon. Unlimited cloud storage is not a personal NAS as far as I can tell, unless you are prepared to pay ACD new prices.


#35

This keeps breaking for me for some reason. It works for a while then

Response: {"error_description":"Client authentication failed","error":"invalid_client"}

#36

I’m experiencing the same issue. Works for about an hour and then I have to reconfig.


#37

I am seldom at a loss for words, but I firmly believe that they do not convey in this case my gratitude and admiration for @ncw You are a gem


#38

Same issue for me, it doesn’t start working again.


#39

Permanent ACD down / Google Upload with 200 Mbit since 24h without any Problem !

Perfect - thank you so much @ncw !


#40

With just 2 days left of my free ACD trial this could not have come at a better time. I was thinking of just re-downloading all my data again!

Currently getting between 42-50MB (400Mb) pulling from ACD to Google so may just make the full transfer of 12.3TB if Amazon don;t cut me off too quickly.

Thanks for this @ncw!!!


#41

Worked today fine, no idea what changed.


#42

I’ve managed to track down one cause of this from a user which used the latest beta on their PC to get the tocken, but were running an older version on the place where the files were being copied. You need the latest beta in both places.


#43

Are you configuring on one machine and copying the config to another? If so make sure you are using the latest beta on both machines.