Proxy for Amazon Cloud Drive


#37

I am seldom at a loss for words, but I firmly believe that they do not convey in this case my gratitude and admiration for @ncw You are a gem


#38

Same issue for me, it doesn’t start working again.


#39

Permanent ACD down / Google Upload with 200 Mbit since 24h without any Problem !

Perfect - thank you so much @ncw !


#40

With just 2 days left of my free ACD trial this could not have come at a better time. I was thinking of just re-downloading all my data again!

Currently getting between 42-50MB (400Mb) pulling from ACD to Google so may just make the full transfer of 12.3TB if Amazon don;t cut me off too quickly.

Thanks for this @ncw!!!


#41

Worked today fine, no idea what changed.


#42

I’ve managed to track down one cause of this from a user which used the latest beta on their PC to get the tocken, but were running an older version on the place where the files were being copied. You need the latest beta in both places.


#43

Are you configuring on one machine and copying the config to another? If so make sure you are using the latest beta on both machines.


#44

Working amazingly thus far. Thanks!


#45

Yeah I saw the bug report, but I had the same issue with the latest beta unless the -latest package in the file listing wasn’t the latest. I had the same issue on osx and linux. It’s working now without issue so I have no idea what happened. I tried to log the error and it just didn’t occur.


#46

I’m doing the config for each system individually. Latest Beta. I just wiped my config file and am trying again. And I’m only doing one instance at a time now. Before I had other CMD’s doing other operations.

Edit: It’s been quite a while and it works now. Remaking a fresh config took a while but has been working great. I’m transferring from ACD to my GSuite at a mindblowing 4.5Gbps.


#47
Response: {"error_description":"Client authentication failed","error":"invalid_client"}

I used to get the above error too when I edited my existing remote with the main post steps.
Fixed it by deleting the existing remote config and then creating a new one with above steps.


#48

It appears proxy no more work :+(


#49

Seems there’s an issue when copying config: If two clients refresh the config one after the other, the latter one will be invalidated. For server users, I suggest forget about the remote config stuff and use w3m instead.


#50

Does this work anymore? Because I cant make it work. It seems Amazon has disabled it.


#51

Works fine here - As ncw suggested, might be the config. Check your version.

One has been running for 198h without problems and another machine has been running for 48h without problems. Got two machines syncing from Gdrive to Amazon at the same time.


#52

This is “somewhat” working for me … but extremely slow speeds; <100 kbps on a 1gbps connection.

-vv shows:

DEBUG : pacer: low level retry 2/10 (error HTTP code 400: "400 Bad Request": response body: "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<Error><Code>InvalidArgument</Code><Message>Only one auth mechanism allowed; only the X-Amz-Algorithm query parameter, Signature query string parameter or the Authorization header should be specified</Message><ArgumentName>Authorization</ArgumentName><ArgumentValue>Bearer Atza|...</ArgumentValue><RequestId>...</RequestId><HostId>...</HostId></Error>")

Any way to speed this up?


#53

Works like a charm!
I’ve set up acd on my headless Raspberry Pi. Instead of using the remote setup as described here https://rclone.org/remote_setup/ I just ran the normal setup (see ncw’s first post) on my windows machine until I got the token. It’s shown in the cmd and can easily be copied from there.

Thank’s a lot to @ncw and the anonymous donor of the credentials! You are awesome!

The only drawback remaining: acd is getting unattractive anyway, because of changing the conditions: https://www.amazon.com/b?node=16591160011


#54

I’ve been having the same issue as @ZeroG. Has anyone else figured out what the issue is or how to work around it? The proxy was working flawlessly prior to these errors and the config hadn’t changed (though I’ve tried recreating the acd remote to no avail). Still having the same issue on the newest beta as of 6/26 too.


#55

@transcendenz, @ZeroG

Try adding --acd-templink-threshold 0 to your rclone command. It seems like ACD has changed the file size threshold for downloading via a tempLink. By setting it to 0, a tempLink is always used. Worked for me at least.


#56

That seems to work for me too, thanks @fgump!