Proxmox backup script - not working

What is the problem you are having with rclone?

I have tried to follow this tutorial: GitHub - TheRealAlexV/proxmox-vzbackup-rclone: This is a vzbackup hook script that backups up your proxmox vm's, container's and pve config's to remote storage using proxmox's native vzbackup tool and rclone. to use rclone in proxmox and upload backups to drive.

Then used this: Google drive to configure it and I got no issues.

I can use "rclone copy /mnt/pve/disco4/dump remote:proxmox" in my host and the content of the folder "dump" is uploaded to my drive /proxmox folder, but when I use the script to do it automatically (created when I cloned repository and only modified to add folder and max age) it doesn't work.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: debian 11.6 (64 bit)
  • os/kernel: 5.15.104-1-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)


The rclone config contents with secrets removed.

type = drive
client_id = #######
client_secret = ########
scope = drive
token = {"access_token":"########>
team_drive =

A log from the command with the -vv flag

This is the log from proxmox:

INFO: rcloning /var/tmp/proxmox-17WuMfPO/proxmox_backup_proxmox.hammer.local_2023-05-
INFO: 2023/05/27 14:43:40 Failed to create file system for "gd-backup_crypt:/2023/05/27": didn't find section in config file
INFO: Cleaning up
ERROR: Backup job failed - command '/root/proxmox-vzbackup-rclone/ job-end' failed: exit code 1
ERROR: command '/root/proxmox-vzbackup-rclone/ job-abort' failed: exit code 1
TASK ERROR: command '/root/proxmox-vzbackup-rclone/ job-end' failed: exit code 1 command '/root/proxmox-vzbackup-rclone/ job-abort' failed: exit code 1

hello and welcome to the forum,

what is the name of your remote?
the config file uses remote
the script uses gd-backup_crypt

might need to hardcode the config file using something like

The name of the remote is "remote"; where should I add "--config=/root/.config/rclone.rclone.conf"?

ok, but from your script gd-backup_crypt:/2023/05/27": didn't find section in config file

i am not not familar with that tutroial.
normally, add to the rclone command, as with any flag.

Maybe I could modify the name of my remote to fit the one in script? It's easier this way and I don't really care about the name.

Edit: exactly; I only had to change my remote name to the one in the script and now it works perfectly. Thanks!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.