Problems with a OneDrive Mount on macOS

I am trying to use rclone mount on macOS, to replace the official OneDrive client.

This is how I start the mount:

rclone mount \
    onedrive: ~/OneDrive \
    --volname "OneDrive" \
    --buffer-size 64M \
    --vfs-read-ahead 512M \
    --vfs-cache-mode full \
    --vfs-cache-max-age 168h0m0s \
    --vfs-cache-max-size 100G \
    --vfs-cache-poll-interval 30s \
    --vfs-write-back 5s \
    --log-level INFO \
    --log-file ~/Library/Logs/rclone-onedrive.log \
    --rc \
    --rc-web-gui

The problem I have is that, when saving changes to a text file, Apple's TextEdit is freakishly slow, freezing macOS's UI in the process. I don't understand it, as this doesn't happen with VS Code or Vim. It's probably something that's Apple-specific.

One hint I get is that the first time I try saving a file, I'm getting this warning:

This warning only happens once per mount. I'm not seeing it afterward. I also tried disabling Apple's file versioning to no avail (this is the first time I'm bumping into this “feature”).

Anyway, I tried mounting my Dropbox, same parameters, and I am not getting the same behavior with Dropbox. TextEdit still seems to do something odd, like creating a temporary file or directory first, but it's not complaining, or freezing the UI.

TextEdit is unfortunately not the only app that does this. Another one is Apple's Preview (e.g., when editing images or PDF files), and this one hurts :pensive:

Anything that I could do to make OneDrive's mount work better on macOS? Any advice?

UPDATE: added log file

I enabled the DEBUG level, and here's what I got:
rclone-onedrive.log (264.9 KB)

Change the log level to DEBUG, recreate the issue and share the log.

It's hard to say what to fix when there isn't a log file showing what the actual problem is.

Is it OK if I edited this post? I've added the log file, as instructed.

Having started from scratch, it's only reflecting the minimal workflow, from mounting, to uploading one change to a file.

What's the time stamp when it locks up so I can properly take a peek at the log?