Problems moving large files to webdav


#1

Anything larger than 3 or 4 gigs ends with an error. I’ve tried the newest live and various beta builds.
Command:
/home/user/Downloads/rclone-v1.39-linux-386/rclone move -vv --transfers 25 --checkers 8 --contimeout 60s --timeout 300s --retries 1 --low-level-retries 1 --include *.mp4 --stats 1s /home/user/Videos Open:Videos/Videos
Error:
2018/01/01 19:35:38 DEBUG : pacer: low level retry 1/1 (error Put /Videos/Videos/20151020/20151020.DSPGaming.Transformers_-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: net/http: timeout awaiting response headers)
2018/01/01 19:35:38 ERROR : 20151020/20151020.DSPGaming.Transformers
-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: Failed to copy: Put webdav.opendrive/Videos/Videos/20151020/20151020.DSPGaming.Transformers-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: net/http: timeout awaiting response headers
2018/01/01 19:35:38 ERROR : 20151020/20151020.DSPGaming.Transformers
-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: Not deleting source as copy failed: Put /Videos/Videos/20151020/20151020.DSPGaming.Transformers-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: net/http: timeout awaiting response headers
2018/01/01 19:35:38 ERROR : Attempt 1/1 failed with 17 errors and: Put webdav.opendrive/Videos/Videos/20151020/20151020.DSPGaming.Transformers
-_Devastation_PREMIERE_Live_Stream_Oct.6_2015.mp4: net/http: timeout awaiting response headers
2018/01/01 19:35:38 Failed to move: Put webdav.opendrive/Videos/Videos/20151020/20151020.DSPGaming.Transformers
-_Devastation_PREMIERE_Live_Stream_Oct._6_2015.mp4: net/http: timeout awaiting response headers


#2

This looks like the problem…

Are the transfers taking longer than 300s? If you raise --timeout that should fix it I think.

If it does then I probably need to put some more info in the docs for the webdav client.


#3

Hi, thanks for your input.

I removed that flag from my command and it fixed the problem for files that are 4 to 8 gigs. But incredibly large files, 10 gigs or higher still do not upload.


#4

Try setting the timeout longer so --timeout 60m. If that doesn’t work can you post a log with -vv --dump responses please?


#5

Hi, i have the same problem, if i upload files with more then 10GB, i changed the timeout to 240m

my log:
DEBUG : pacer: low level retry 1/1 (error Put https://webdav.opendrive.com/“Folder1”: read tcp ...:37840->...:443: i/o timeout)
ERROR : “Folder1”-: Failed to copy: Put https://webdav.opendrive.com/“Folder1”: read tcp ...:37840->...:443: i/o timeout


#6

Hmm, looks like I need to revisit this. please make a new issue on github and I’ll figure out what to do there - thanks!