Problem with permission on Windows

What is the problem you are having with rclone?

Hello, I have a problem with mounting in Windows, I was using version 1.57, but on 1.58 I still have the problem with Windows 10.
When I mount a drive with SYSTEM as user with MOUNT, there are two users: Everyone and System. System has all the rights, but "everyone" can't write and modify. I don't know what to put so that everyone has the same access as system.

Thanks for your help.

Run the command 'rclone version' and share the full output of the command.

1.57 , 1.58

Which cloud storage system are you using? (eg Google Drive)

all cloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

start /MIN "Montage : MEGA" "D:\Bureau\bureau_vrac\rDrive_system\bin\rclone.exe" --config="D:\Bureau\bureau_vrac\rDrive_system\cfg\rclone.conf" --cache-dir "D:\Bureau\bureau_vrac\rDrive_system\.cache" --cache-chunk-path "D:\Bureau\bureau_vrac\rDrive_system\.cache\chunk" --cache-db-path "D:\Bureau\bureau_vrac\rDrive_system\.cache\db" --cache-tmp-upload-path "D:\Bureau\bureau_vrac\rDrive_system\.cache\tmp" --log-level INFO --log-file "D:\Bureau\bureau_vrac\rDrive_system\log\MEGA.log" mount "MEGA:/" M: --vfs-cache-mode full --vfs-cache-max-age 1h0m0s --vfs-cache-poll-interval 5s --file-perms 0777 --transfers 1 --network-mode

The rclone config contents with secrets removed.

exemple for MEGA

type = mega
user = USER
pass = PASS

A log from the command with the -vv flag

2022/03/22 08:39:01 INFO  : mega root '': poll-interval is not supported by this remote
2022/03/22 08:39:01 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
The service rclone has been started.
2022/03/22 08:39:06 INFO  : vfs cache: cleaned: objects 14 (was 14) in use 0, to upload 0, uploading 0, total size 0 (was 0)

Hi, welcome to the forum.

Try the following, instead of your --file-perms 0777:

-o FileSecurity="D:P(A;;FA;;;WD)"

(requires WinFsp 2021, version 1.9, or newer)

Instead of using a set of default permissions, based on current user/group, tweakable with --file-perms and --dir-perms, this sets the exact permissions to be used. I'm not speaking SDDL fluently, but that string should set full access (FA) to everyone (WD) - and nothing else.

More info:

1 Like

thank you, it seems to work, now there is only everyone in total control, this is what I was looking for! thank you!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.