Problem with Option _netdev in fstab, rclone v1.58.0-beta.5885


i am using rclone v1.58.0-beta.5885 on Raspian bullseye 32bit.
According to this

since V1.57 do not need a helper script any more. rclone now can be used in native mode with mount like davfs2 for webdav

As you can read, an example for /etc/fstab is
gdrive1: /mnt/testmp rclone rw,noauto,nofail,_netdev,x-systemd.automount,args2env,vfs_cache_mode=writes,config=/etc/rclone.conf,cache_dir=/var/cache/rclone 0 0

now, you should me able to mount manually by entering
mount /mnt/testmp

When I try this, bash is saying that an option cannot beginn with a '-' or a ''
When I remove '
' of netdev, then the command will pass mount command, but netdev is passed to rclone.
rclone command is now saying --netdev unknown option

What do I have to do?

beside this problem, v1.58.0-beta.5885 is the newest beta which is instalable on my RaspberryPi with armvl7 deb package. all newer versions the the package installer says error while installing.

This is discussed here

There is a workaround you can try too, but in short, removing the _netdev should fix it.

Which raspberry Pi are you using? And what error do you get from the installer?

Ah, Thanks, I will follow the problem on Github Thread.
I ve tested it without the option _netdev and it worked. How important is this option?

May I ask you something about autofs?
I am using autofs for any network-mountings.
Does autofs need an entry for each mounting in fstab, or are the enties in fstab only for manually mounting via mount-command?
As you know, autofs has a masterfile auto.master, and map-files. You can define mount options in masterfile and in map-file. Are there any options you can use only in one of the, only in auto.master or only in map-files? Do you know this?

I have a rPI4 with 4GB RAM. Raspian bullseye is still 32bit, not 64bit on it.
I tried this:
apt install /tmp/rclone-beta-latest-linux-arm-v7.deb
and got error (translated from german to english):
Error while processing Archiv rclone-beta-latest-linux-arm-v7.deb (--unpack)
Package-Architecture (arm) doesnt match with system (armhf)
sub-process /usr/bin/dpkg returned an error code (1)

But rPi4 is arm-v7
with arm-v7.deb file of beta5885 and earlier, the installation works

By the way, when we talk about installation, do you know that each Version of a deb-package of rclone is removing an installed package rclone-browser? Is there a reason for this?

This is what it does. It is an instruction to the mount command used when your system is booting up. If it works without then you probably don't need it.

          The filesystem resides on a device that requires network  access
          (used  to  prevent  the  system  from  attempting to mount these
          filesystems until the network has been enabled on the system).

The fstab entries are only for mounting manually so you don't need them for autofs.

I don't know the answer to that!

Ah, looks like that has changed...

$ dpkg -I /mnt/tmp/v1.57.0/rclone-v1.57.0-linux-arm.deb | grep Architecture
 Architecture: armhf
$ dpkg -I /mnt/tmp/v1.57.0/rclone-v1.57.0-linux-arm-v7.deb | grep Architecture
 Architecture: armhf

But with the latest beta it is

$ dpkg -I /mnt/tmp/rclone-beta-latest-linux-arm-v7.deb | grep Architecture
 Architecture: arm
$ dpkg -I /mnt/tmp/rclone-beta-latest-linux-arm.deb | grep Architecture
 Architecture: arm

Can you open a new issue on Github about that please and we can get it fixed.

Its almost certainly a change in the nfpm tool rclone uses for making the .debs.

Note that you can install these debs anyway (they should work) with dpgk --force-architecture -i whatever.deb

I don't know the reason for that. It is probably because rclone-browser declares a Conflicts: rclone in its package as it supplies its own rclone binary.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.