Problem with moving

i have a problem when moving files or directories from folder to folder all files already uploaded!. a few days ago it went without any problems but I had version v1.36 with api v1. now i use rclone v1.37 with api v2

2017/10/01 12:35:19 ERROR : myfolder: Dir.Rename error: Error in call to API function “files/get_metadata”: request body: path: The root folder is unsupported.

is it possible that dropbox disabled the function?

## UPDATE ##
files go to move now, only the directories are affected which cannot be moved
rename directories doesn’t work either

Can you give an example of a command which fails, along with the log with -vv please?

sorry for the delay, I tried to rename a folder this doesn’t work, the system always says input/output error
files he can rename/move it works great! but do not move or rename the folders.
if you need more details let me know but i think all other guys can replicate the problem?!

mv test test2
mv: cannot move ‘test’ to ‘test2’: Input/output error

Rename: err=Error in call to API function “files/get_metadata”: request body: path: The root folder is unsupported.

here is the log with -vv

I’ve fixed this now - try the latest beta and it should be working.

it works sincere thanks!

1 Like

give is a possibility to optimize rename/move?

if I rename or move files it is very fast for directories it takes a very long time, does it directly move only the folder or every file count in the directory? a directory with 10 files will take about 2 minutes to moved. does the option --fast-list bring a optimized move?

in the time the folder is moved, the whole dropbox mount hangs and cannot be opened or listed

Dropbox implements DirMove so it should just move the directory which should be very quick.

How are you moving files? Maybe whatever you are using is renaming them individually?

I’m using the linux command rename: mv folderold foldernew move: mv path/folderold path/foldernew
it doesn’t matter if I do it via ftp or directly on the linux shell it takes just as long

I can move or rename files with the ftp or on the direct linux shell that goes very fast!

it’s just the folders that are very slow

I’ve been unable to replicate this - I’ve tried moving directories with 100s of files in and then only take a few seconds.

I’ve been trying with the latest rclone beta - have you?

yes i have tested the latest beta version, how big is your dropbox or is it empty and fresh?

I have 1.2GB of files in ~6000 objects so not masses of stuff, but not empty either.

What do the slow rename directories have in? How many files and directories do they have in, in the first level and in total?

i think i had more as 300.000 files uploaded, dirlisting, browsing and downloads/uploads are very fast, then it’ll probably be the amount of files, which does not explain why moving files is faster as directorys.

I think it might be because it was moved to different servers. and then it might be shifted to a new server node and so the times could come up. that’s what I’d think

That sounds like a reasonable explanation - dropbox doing some sort of housekeeping when you move the data. I don’t think it is anything rclone is doing.