Problem converting .odt to google doc format when using bisync

What is the problem you are having with rclone?

Hi, I am new to RClone and I am trying to sync a folder from my linux pc to a google drive folder. I am not absolutely sure about the command I'm using, it's what I was able to do from reading the documentation and the forum, but it's still not working right.
My problem is when there's a google doc in the drive, or when there is a .odt in the source. I tried using --resync, tried using --drive-import-formats instead of export, but nothing I did behaved like I needed it to.

I would really appreciate some help with this.
Thank you.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: debian bullseye/sid (64 bit)
  • os/kernel: 5.15.0-71-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone bisync --progress -vv --include "{*.gsheet,*.gdoc,*.gslides,*.docx,*.xlsx,*.pptx,*.gdraw,*.gtable,*.gform,*.pdf,*.odt}" google-drive:"Waterdeep" ~/Documents/Waterdeep --drive-export-formats odt,docx --verbose

The rclone config contents with secrets removed.

Current remotes:

Name                 Type
====                 ====
google-drive         drive

A log from the command with the -vv flag

Paste  log here

Do you have google docs you need syncing? I can see these might well complicate the sync as they don't have a fixed size and could easily confuse bisync.

If you don't have google docs you want syncing then I'd turn off the google docs import and export with --drive-skip-gdocs and that should make bisync behave.

I would prefer to use google docs, but I could use .odt or .docx if it would be too complicated to sync google docs.

I think that google docs probably won't bisync properly as they don't have a size.

If you turn off docs export then normal doc files should work fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.