Potential workaround for slow Google Drive speeds

I've been trying to migrate off of GDrive onto Backblaze for the past few days and kept getting speeds maxing out at about 4 MB/s going to Backblaze. Yes, I used my own client_id, so it wasn't that.

Originally I thought it was Backblaze being super slow, but I tried using rclone to copy files hosted on a VPS to it and was getting much higher speeds.

I also tried using rclone to download locally from the GDrive and was also getting much faster speeds.

After a lot of searching, I found a thread that was solved by using the --bind flag and binding it to your IP (after disabling IPv6). There was also a post that mentioned it was possible that you're blacklisted, so it occurred to me that perhaps it was because I was using a VPN (that was also using IPv6), I was getting throttled.

So I disabled IPv6, even set the DNS server to 8.8.8.8, and disconnected from the VPN and it STILL didn't work.

Finally, I decided to try running rclone from a second VPS (Oracle free tier) and HOLY SHIT, I fixed it!!!

Somehow, it appears as though GDrive will throttle your rclone transfers EVEN IF YOU'RE NOT DOWNLOADING THE FILES TO YOUR LOCAL MACHINE.

Not sure if anybody else has run across this, but hopefully it helps someone out there in the future.

The command I used was:

rclone sync gdrive: b2: --drive-chunk-size 64M --transfers 10 -vv -P

1 Like