Possible config file behavior regression for root_folder_id

What is the problem you are having with rclone?

Same config returned no results from 1.53.0 - 1.53.3 but works in 1.52.2. Started using a service account and impersonation in 1.52.2.

Looks like this may be a regression for this topic in the forums

/rclone-gdrive-no-longer-returning-anything/17215

removed root_folder_id from conf file and 1.53.3 is successful again. I don't recall when this parameter made it into the conf file.

What is your rclone version (output from rclone version)

1.53.0-1.53.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04.5 LTS

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

With root_folder_id

rclone about gdrive: (Successful)
rclone lsd gdrive: (No results)

The rclone config contents with secrets removed.

root_folder_id = "0AN2CpkXGaRUVUk9PVA"

This line looks to be the culprit, removed/commented out and rclone 1.53 is successful. Don't recall when this was populated.

A log from the command with the -vv flag

With root_folder_id

2020/12/14 10:02:37 DEBUG : rclone: Version "v1.53.3" starting with parameters ["./rclone" "lsd" "gdrive:" "-vvvv"]
2020/12/14 10:02:37 DEBUG : Using config file from "/home/user/rclone-v1.53.3-linux-amd64/rclone.conf"
2020/12/14 10:02:37 DEBUG : Creating backend with remote "gdrive:"
2020/12/14 10:02:38 DEBUG : 6 go routines active

Without root_folder_id

2020/12/14 10:02:49 DEBUG : rclone: Version "v1.53.3" starting with parameters ["./rclone" "lsd" "gdrive:" "-vvvv"]
2020/12/14 10:02:49 DEBUG : Using config file from "/home/user/rclone-v1.53.3-linux-amd64/rclone.conf"
2020/12/14 10:02:49 DEBUG : Creating backend with remote "gdrive:"
2020/12/14 10:02:50 DEBUG : Google drive root '': root_folder_id = "0AE6QRLYPtaeBUk9PVA" - save this in the config to speed up startup
2020/12/14 10:02:50 DEBUG : Empty-Trash: No export formats found for "application/vnd.google-apps.script"

For a while rclone was caching the root_folder_id when it shouldn't have been. Unfortunately it looks like in your case it cached an incorrect root_folder_id.

Removing it is the correct thing to do.

This might have been caused by changes to shared / team drive handline.

Do you also have team_drive set maybe?

No team drive. I may look into it in the future but haven't found the use case for it yet.

Only recent change was that I started using an internal service account and impersonation for gsuite business.