Possible blue screen with rclone 1.38?

I am adding this topic to see if anyone else has similar issue. It might be caused be something else than rclone. Rclone is suspicious though :confused:

I was using rclone 1.37 occasionally and yesterday I tried version 1.38. I usually just let it sync in background and do something else (or nothing). The BSOD is very rare for me, but I have got it two times yesterday, in both cases the rclone was running before the crash. I went back to version 1.37 and finished the backup successfully, no crash since then.

I am using backing up to Backblaze B2 with these parameters:
sync --fast-list --verbose=1
For 1.38 I added
–b2-hard-delete
(though not much needed as I use “cleanup” at the end)

One of the BSODs diplayed UNEXPECTED_STORE_EXCEPTION. For the other one I cannot tell as I found the computer completely crashed and refusing to boot - so probably similar issue (fortunately it booted up after turning it off and on again).

It could have been a faulty drive or something completely unrelated, but since it only happened during the rclone 1.38 run, I am alert now. If I will be able to tell more, I will add the new information.

I am on Windows 10 Pro, 64bit.

This is most likely not related to rclone or WinFsp.

Were you using rclone mount? If not I think it is pretty hard for rclone to cause a BSOD without there being a bug in something else (eg network drive), or a problem with your computer (eg faulty memory).

No mount, just “plain” rclone. I find it very weird, that the bug would be in this application. Indeed it should be more likely a hardwre failure. But I use my computer extensively and the BSOD happened only twice (say, during the last year) and in both cases the rclone was running and I don’t run it very often either.

I am now trying to find if it was a coincidence or if there is someone having similar experience.

If you aren’t using rclone mount, rclone is an entirely userspace program so shouldn’t be able to cause BSOD which are kernel level problems. So there is almost certainly a problem, but if rclone is causing a BSOD then it is likely a driver bug, a kernel bug or a hardware problem,

UNEXPECTED_STORE_EXCEPTION is something to do with disk drives as far as I know so it would probably worth running a full checkdsk on your disk.

If that was my computer I’d run memtest86 on it for 24hours to make sure the hardware is solid, then stressdisk to check the disks

Thanks for the tip. I already did some lightweight tests before posting here, but I will try these more thorough ones.

Just an update: No errors were found so far and no BSOD occurred, even though I tried again the newest version of rclone, which ran during the previous BSODs. So in the end it seems it was some weird coincidence.

Thanks for the replies and tips though and good luck with rclone!

Thanks for the update. Maybe it was alpha particles :wink:

1 Like